Syncing client crashes with "Network Error:99"

I’ll join in.

Files created on the client will not be synced to the server, client log show “Network Error 99”

Everything freshly setup on Friday in a new Ubuntu 22.04 LXD container, mostly following

Everything else seems to be working fine.

Apache proxy config on the gateway container is

<VirtualHost *:443>
  ServerName cloud.example.org
  ServerAdmin webmaster@example.org

  AllowEncodedSlashes On

  RewriteEngine On
  RewriteRule ^/\.well-known/carddav https://%{SERVER_NAME}/remote.php/dav [R=301,L]
  RewriteRule ^/\.well-known/caldav https://%{SERVER_NAME}/remote.php/dav [R=301,L]
  RewriteRule ^/\.well-known/webfinger https://%{SERVER_NAME}/index.php/.well-known/webfinger [R=301,L]
  RewriteRule ^/\.well-known/nodeinfo https://%{SERVER_NAME}/index.php/.well-known/nodeinfo [R=301,L]

  Include /etc/letsencrypt/options-ssl-apache.conf
  Header always set Strict-Transport-Security "max-age=15552000; includeSubDomains"

  SetEnvIf Authorization "(.*)" HTTP_AUTHORIZATION=$1
  ProxyPreserveHost On
  ProxyPass / http://10.90.60.236:80/
  ProxyPassReverse / http://10.90.60.236:80/
  SSLCertificateFile /etc/letsencrypt/live/example.org/fullchain.pem
  SSLCertificateKeyFile /etc/letsencrypt/live/example.org/privkey.pem
</VirtualHost>

I have been hitting “Network Error 99” and the Desktop client freezing up since upgrading to NextCloud 25. I finally found a fix discussed in GitHub issue 5094, in summary this is what fixed it for me:

  • On the client, disable any upload speed limits
  • On the server, edit config.php to add the line 'bulkupload.enabled' => false,

From the discussions on GitHub, it sounds like the upload speed limit and bulk upload features are buggy in the latest server/desktop releases.

10 Likes

Hi @joshuaprince , thx for your fix, it’s work for me, after edit the config.php and restart, the client have sync without error !

Worked for me also. Just added the line into config.php. Thank’s Joshua…

Works fine here to ! i had no limits enabled at all but the function some how is broken and cause lots of errors :confused: thanks for your solution !

Hello,

I have the problem of these errors 99 on a fresh install.

This solved it for me perfectly. Had to wait forever for Nextcloud to revalidate the sync, but then it suddenly finished and got the big green checkmark.