Sync is extremely slow, consuming too much energy

I wiped one of my computers and got my personal files from another one because they were identical, and, transferring over Thunderbolt takes like seconds.

I reinstalled the Nextcloud client and started sync with the files copies from the other computer (also Nextcloud-synced, BTW) and the files already were up on the server, nevertheless it never completed the sync it was stuck for day with the client completely frozen, reacting minutes later after a click utilizing a full core at all times.

Right now my computer is right under the aircon jet because it get really hot if it doesn’t have forced cool air flowing around it.

Like I mentioned, the sync never completed because I wipe all of the files from Nextcloud, disconnected my other synced computer and let it start from a single computer from scratch. It was the same result. Days passed and no completion.

Next, I wiped Nextcloud itself and reinstalled on a whole different OS (RHEL vs UbuntuServer), and once again I’m facing the same result. It’s been a week since that last time and sync is still going and the client is stuck, clicking on it on the menu bar messes up my computer and the dropdown menu stays there even if I’m doing something else already in another app. Open the full window takes a good 5 minutes, with 2-3 minutes to change between the tabs. It doens’t crash the system though, everything else is fast, only the Nextcloud app is slow. I installed from Nextcloud directly and with Homebrew–several times. I even wiped my user account in the computer to make sure no lingering configuration files were detected.

I would much rather drop the files over SMB3 or NFS but I don’t think Nextcloud allows that because of its hashing thingy.

The server itself and Nextcloud on the browser is very responsive, it has basically no load:

It has only four cores and which is basically two because of the hyperthreading. I haven’t had to increase core count at all. It’s also running a couples of websites and they are blazingly fast.

Maybe it’s a problem with my files, something corrupt perhaps, I thought, but every other sync or copy operation would most likely fail too.

I installed Synology Drive, offered by some of my NAS units and it completed sync in about 10-15 minutes. I only have about 10GB of data. It’s like 30000 files, according to the copy dialog I got when I was duplicating the file structure before starting sync (just in case something went wrong with the clients…like it did).

My instance is very unimpressive but it’s also very underloaded. It runs on vSphere with all-flash storage in RAID1+0, it’s fast enough to handle a single user, I’d say, yet it doesn’t. I mean, if that’s even the culprit–I don’t know. How can I get stats or a log on what’s happening? Why is it so slow?

Thanks !

If you’re willing to start your NC from scratch, you could do the following:

  • remove your user account in NC desktop
  • remove/reinstall your NC instance
  • create your user in NC
  • copy all your files to NC using NFS/SMB/SCP/RSYNC
  • run occ files-scan [user] on your NC instance
  • create new user account on NC desktop and point to the same data on your Mac (please make sure, that it’s the same layout as on your NC user account)
  • don’t choose “clean sync”, if asked

That should cause NC desktop to check/compare, but not upload/download the files already there.

1 Like