Sync error: "Server stopped accepting new streams before this stream was established"

I’m running a Nextcloud instance on my private server at home. Trying to sync files from my laptop (Arch Linux) using the Nextcloud client, I sometimes see this error for some files:

“Server stopped accepting new streams before this stream was established”

This seems to happen for random files. AFAICT they are not particularly large or special in any other way. Syncing of other files seems to continue normally afterwards.

I couldn’t find any errors in the Nextcloud or nginx logs, nor in the systemd journal on either the client or the server. Are there any other logs I should check?

Googling the error message only brings up the code that produces it (, which tells me only that this is somehow related to QT maybe?

Anybody got an idea?

Nextcloud version: 16.0.4 (Arch package)
Operating system and version: Arch Linux, kernel: 5.2.10-arch1-1-ARCH
Apache or nginx version: nginx 1.16.1-1 (Arch package)
PHP version: 7.3.9 (Arch package)

Nexcloud config.php:

$CONFIG = array (
  'instanceid' => '...',
  'passwordsalt' => '...',
  'secret' => '...',
  'trusted_domains' => 
  array (
    0 => '...',
  'datadirectory' => '/var/nextcloud',
  'dbtype' => 'pgsql',
  'version' => '',
  'overwrite.cli.url' => 'https://...',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost:5432',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'nextcloud',
  'dbpassword' => '...',
  'installed' => true,
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'maintenance' => false,
  'mail_smtpmode' => 'smtp',
  'mail_smtpsecure' => 'ssl',
  'mail_sendmailmode' => 'smtp',
  'mail_from_address' => '...',
  'mail_domain' => '...',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpauth' => 1,
  'mail_smtphost' => '...',
  'mail_smtpport' => '...',
  'mail_smtpname' => '...',
  'mail_smtppassword' => '...',

I am facing the same issues.

I am using the mariadb-cron-redis fpm docker image with nginx-proxy and the letsencrypt companion app.

My PC is running Manjaro, so kind of arch, maybe its this. But i am not sure because i just setup a fresh build of nextcloud with docker and at the same time switched to manjaro and are not able to test the nextcloud client on Windows. So I am actually not sure where this error has its home. Either Manjaro, Nextcloud with Docker, or my nginx-proxy-letsencrypt config.

Btw i am not sure how to change these php settings and maybe it has something to do with too low memory?


The Download speed via Nextcloud Client or Web Access is kind of slow with only ~ 3MB/s. Via SFTP i get about 15 MB/s and i dont like the fact that its getting this slow just because there are some php layers or what ever.

I’m seeing the same issue., the error “Server stopped accepting new streams before this stream was established” sporadically pops up.
Currently I’m trying to debugging this issue and try to figure out if this is related to the reverse proxy I have in front of my nextcloud instance or if it is the nextcloud instance itself.
@ra_kete: How are you connected to your Nextcloud? Are you connected directly or via a reverse proxy which does the ssl encryption?

I am also seeing this issue on a fresh NC 17 instance.

Server Details:

  • Debian 10
  • Docker (docker-compose):
    • Nextcloud latest
    • Mariadb latest
    • Letsencrypt latest
  • Reverse proxy setup via letsencrypt subdomain

Client details:

  • Arch Linux (Kernel 5.3.1)
  • Plasma Desktop
  • Connection via Wifi

Not sure if this is useful info but my router (Netgear R7800) is running OpenWRT which I had to flash to get NC working properly via reverse proxy.

No issues on my other laptop which is running macOS mojave.

I will say it appears my NC files are still syncing even though I see this error message, so we will see. Perhaps there is an issue in the NC Client build available in Pacman repos.

I got saime failure with Desktop App 2.6.0 and NC17
with 2.5.2 there is no Problem.

The same issue here.

*Server stopped accepting new streams before this stream was established *

Windows 10
NC17 with 2.6.0stable-Win64
PHP 7.2.23

This appeared while syncing a large amount of files via the desktop client. A number of files before and after this message were listed on the ignore list (not sure if these issues are related).

Same here,

Windows 7,
NC 17, mirall/2.6.0stable-Win64 client
PHP 7.3,

Also hit some ignored files and then this came up during sync…

Same issue here

Win 10
NC 17.01
PHP 7.3

Same here.

Server Centos 7.7 / Apache / PHP 7.2 / NC 17.01
Desktop Client 2.6.1stable-Win64

I have the same issue. Same configuration as already mentioned here. The error dissapears after a while but comes back and so on…

Same here… Anybody has a solution?

Same issue here.
Any solution insight?

Same issue here.

Client 2.5.2 - no problem
Client 2.5.3 and newer - “Server stopped accepting new streams…”

In my case, it’s a single but quite big excel file (35 MB). If you open and save it, the error occurs. Renaming, deleting or moving the file is possible without Problem. But changing it - no way.

  • Windows Client
  • Nextcloud 17.0.1
  • PHP 7.3
  • MariaDB 10.3.18

Having the same issue on several Windows Clients and Accounts.

  • Nextcloud 17.0.1 (had this problem on the last versions too)
  • PHP 7.3

Using the 2.5.2 client fixes the problem so far.

same issue with

nextcloud 17
windows client 2.6


Just to add me to the list. I’m having the exact same issue on Mac OS Catalina with the 2.6.2 stable version, Nextcloud 17, nginx/php 7.3 not in docker.

The error pops with many small files it seems. It’s fast, then I get the error and a random time after, the app doesn’t sync anything anymore and I have to manually pause/unpause the sync.

same issue

is there a solution ?

nextlcoud : 17.02
2.6.2 client

Same issue, problem started after client update to 2.6.2.

Same here.

Same here.