Sync Client: Folders and files disappear and/or are not synced (Windows/Linux/Mac)

Once in a while we are running into strange sync problems we still don’t really understand. There are actually 2 cases which might or not be connected.

Case 1 - Folders and files disappear on client / not all files/folders are synced from Server to client
This has happened several times after an minor version update of the server (but not only). Suddenly some files and folders on the client disappear. They remain on the server and not all users seem to be affected. There is no error in the sync client. Manually excluding/removing the affected subfolder from the sync and readding it again fixes the sync and all files are downloaded again to the client. But sometimes some files in the excluded folder remain locally and need to be deleted manually in order to make the sync work again.
Force sync doesn’t help neither.

Case 2 - Files are not uploaded to the Server
Some files are not uploaded (folders seem to be OK in general) to the server. There are cases where folders remain empty and other where only a few files are uploaded but not all. There are no errors in the Sync Client. Removing all the files locally and readding them fixes the problem. Removing the subfolder from the sync and readding it does not. Neither does a forced sync.

I’m aware that this description is not very detailed. I have been able to figure our how to reproduced the issues reliably. I have several nextcloud instances running on two different server environments.

I hope someone here can help me to dig more into this issue. I’ll be glad to provide more information.

1 Like

Perhaps an idea to build an option / box in the Sync program to choose how the files will be removes? If you remove a file in the cloud it will remove the file on the local / client side at the momment…

@Taro I expect to the cloud and local folder to be in sync. Not deleting a file locally if it’s deleted on the server somehow goes against the idea of a file synchronization tool.
The problem mentioned in my question is exactly about the fact that the folders become out of sync. And this is what worries me seriously.

This has happened to me as well, several times. I run a nextcloud server with version 13.0.3 and two OpenSUSE Tumbleweed clients with Nextcloud Sync Client Version 2.3.3.

It seems to happen intermittently, as FreeMinded mentioned it could very well coincide with updates of the server.

Usually about 70 GB worth of files disappear on my notebook client (not my desktop client for some reason), and I need to re-add the folders/account to resync it properly.

Obviously this doesn’t exactly instill confidence and I’d like to +1 this problem in hopes of getting a fix in a future release. I’d be happy to supply logs etc. to help in the troubleshooting if possible.

Well, a google search brought me to this post. I know it’s old, but sounds exactly like the weird things going on with my setup.

Server 14.0.4
Client Version 2.5.0v2.5.0 (build 20181112)

Went to open my local folder and 17GB of work files vanished!
The client also reflected the missing files, but when I look on the server they’re all there.

I tried forcing a sync with the client, but it kept reporting everything synced.
I had to remove the sync connection and re-create it, to scan and re-download the missing files, a process that took about 6 hours!

This is not good if NextCloud has a history of this, it translates to 6 hours of loss productivity!
This needs to be resolved ASAP!

Thank you.

Unfortunately, this topic does not seem to have received a lot of attention. Since a couple of months I am struggling with the same problem.

My configuration:

  • Server on raspbian: version was 14.0.4 has recently been upgraded to 19… however this upgrade did not seem to have changed the behaviour.
  • one client on a windows10 machine, version 3.0.3
  • one client on a fedora 31 machine, version 2.6.5

I have 4 Folders that I keep synchronised between those 2 clients with nextcloud. It has been working fine for a long time now.
A couple of months ago, on one of those folders I unselected a subfolder on my fedora client, and later on selected the folder again.
Since then the following happens: the whole folder contents (not only the previously unselected subfolder) disappears on my fedora client. The folder itself is there, but it is empty.
On the nextcloud client application however, it appears as synchronised (showing the folder name and the correct size as well as the subfolders with their names and sizes).
Unselecting the whole folder and applying the change makes the folder itself also disappear on my fedora client (which is the correct expected behaviour). Then re-selecting the folder immediately starts synchronisation and copies all the files back onto my fedora client, only to see that after a couple of hours, the folder is empty again.
In the meantime the nextcloud client on my windows machine works perfectly as expected, everything is there.

One more thing happened during that time: I wanted to upgrade my fedora client to 3.0.3. Since this version is not available in the fedora31 repos, I decided to install the appimage from the nextcloud website. Unfortunately I did not uninstall the 2.6.5. version before installing the 3.0.3 appimage. For a couple of days, both clients were installed on my fedora client. Then I started seeing this problem and decided to remove the 3.0.3. appimage, hoping that this would solve the problem, which it did not.

Could the problem be caused by a left-behind configuration file from the appimage 3.0.3.version that conflicts with the 2.6.5. client config ? If yes, which file could that be ?

1 Like

Hello,
I have to ad myself to the group having this kind of problem. The first time it happened I wasn’t sure I didn’t cause the problems myself although unlikely. After that it happens once in a while that certain clients have issues with what is actually on the server and what is synced. Having the files ON the server is better than NOT having them there, which also happened a while ago. I had several Gigs of data locally but NOT synced to the server. That caused conflicts when users edited data believing that it was synced…
Since then I have updated several times and at least 2 major versions and find myself facing a similar problem AGAIN!
The case now is that one Mac user created/uploaded a number of directories, renamed some of them to a location I have full access to as both user and member of my admin group. The directories is there in the Web GUI but doesn’t get synced to me on any of my PC-devices!
Since I have a similar setup that many of my fellow forum members have, I spare you the intricate config/device specs for now.

Regards!