Switch to decimal instead of binary

My Nextcloud sometimes shows errors while syncing and after the error disappeared i was not sure if everything was synced or not so i checked file sizes which were different. I realised that it says GB but its actually GiB. Is there a way to to change it to display decimal so i dont have to convert the binary to decimal?

No, there is no option. There was a long discussion back in the days of ownCloud (5 years ago: https://github.com/owncloud/core/issues/13386) where it was decided to keep the “Microsoft” definition of a 1 GB.

Just for the interface, you can probably realize this in the interface. For the client communication, they must use the same definition. Or you check with the developers if they want to change it (https://github.com/nextcloud/server/issues).

Thank you for your answer,
I have no problem using GiB, but as far as i understand people use GB for GB and GiB and i think this is just confusing. I guess i should go see if its possible to change the format from metric in my linux GUI, because nobody will rewrite GB to GiB just for me :smiley:

I have seen the GiB more and more often. However, they are afraid to confuse Windows users with GiB

1 Like

Its a shame, where i live they teach the difference, but as i forget about it cause i was using windows for a long time most people did.
It would be nice to be able to change it in the settings.

Discuss it with the developers. We can’t decide this here. It was quite controversial at that time, perhaps they see it differently, at least label it correctly as MiB.