Swift openstack API and file size over 5GB

I have an OBJECT STORAGE at OVH.
I want to connect it in openstack API to nextcloud to store many files, many are bigger than 5GB

I get the following error when a file is bigger than 5GB.

However a 4gb file will be segmented and rebuilt

but as soon as the file exceeds 5gb, the file is well segmented, well uploaded on OVH but during the reconstruction the error occurs.

I’ve been through a lot of forums and I haven’t found a solution. I hope I’ve been able to give more details about my problem.

[/details]
Nextcloud version _(eg, 20.0.5)_: `25.0.3`
Operating system and version _(eg, Ubuntu 20.04)_: `debian 11`
Apache or nginx version _(eg, Apache 2.4.25)_:  `apache2
PHP version _(eg, 7.4)_: `8.1`

The issue you are facing:


Is this the first time you've seen this error? _(Y/N)_: N

Steps to replicate it:
1.  Upload file size over 5GB in an openstack Swift external storage (v3 in ovh object storage)

The output of your Nextcloud log in Admin > Logging:

Error	webdav	Sabre\DAV\Exception: Impossible de renommer le fichier partiel en fichier définitif.		2023-02-20T15:19:48+0100
Error	webdav	renaming part file to final file failed $renameOkay: false, $fileExists: false)		2023-02-20T15:19:48+0100
Error	files_external	OpenStack\Common\Error\BadResponseError: HTTP Error ~~~~~~~~~~ The remote server returned a "413 Request Entity Too Large" error for the following transaction: Request ~~~~~~~ COPY /v1/AUTH_52634f69eb3d47ddaf5b56a1055b7afb/DOntlikeIT/Win11_22H2_French_x64v1mi-decembre2022%20-%20Copie.iso.ocTransferId1558509433.part HTTP/1.1 User-Agent: GuzzleHttp/7 Host: storage.gra.cloud.ovh.net Destination: DOntlikeIT/Win11_22H2_French_x64v1mi-decembre2022 - Copie.iso Response ~~~~~~~~ HTTP/1.1 413 Request Entity Too Large Content-Length: 108 Content-Type: text/html; charset=UTF-8 X-Trans-Id: txd3bd87a5aae64e88866d9-0063f38184 X-Openstack-Request-Id: txd3bd87a5aae64e88866d9-0063f38184 Date: Mon, 20 Feb 2023 14:19:48 GMT X-IPLB-Request-ID: 05321096:35A9_5762BBC9:01BB_63F38184_B7736AA:1C0B5 X-IPLB-Instance: 42085 <html><h1>Request Entity Too Large</h1><p>The body of your request was too large for this server.</p></html> Further information ~~~~~~~~~~~~~~~~~~~ Visit http://docs.php-opencloud.com/en/latest/http-codes for more information about debugging HTTP status codes, or file a support issue on https://github.com/php-opencloud/openstack/issues.

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
  'instanceid' => 'ocu1nrmwci3d',
  'passwordsalt' => 'bc4leXaZdwdcs+YiNgZ9J2ElNvzywj',
  'secret' => 'wyEZLNr/20Wdc3o9U1bwq8ZSgkxJxi67mT/J2MAy/GXxMkWz',
  'trusted_domains' =>
  array (
    0 => '192.168.0.144',
  ),
  'datadirectory' => '/var/www/nextcloud/data',
  'dbtype' => 'mysql',
  'version' => '25.0.3.2',
  'overwrite.cli.url' => 'https://192.168.0.144',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'nextcloud',
  'dbpassword' => 'VotreMotDePasse',
  'installed' => true,
  'htaccess.RewriteBase' => '/',
  'filelocking.enabled' => 'true',
  'redis' =>
  array (
    'host' => '/var/run/redis/redis-server.sock',
    'port' => '0',
    'timeout' => '0.0',
  ),
  'memcache.distributed' => '\\OC\\Memcache\\Redis',
  'memcache.local' => '\\OC\\Memcache\\Redis',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
);