Swift Object Storage as primary

#1

Hello,

i’m trying to use a swift Object Storage as a primary container for files, using the tutorial (https://docs.nextcloud.com/server/11/admin_manual/configuration_files/primary_storage.html) i edited the config.php with all the required info. I actually get an ‘internal server error’ on file upload and logs says : ‘Guzzle\Http\Exception\CurlException: [curl] 7: Failed to connect to 127.0.0.1 port 8888: Connection refused [url] 127.0.0.1:8888/v1/AUTH_fccf033541744223a9e9xdfdb2c81/NEXTCLOUD2’

‘NEXTCLOUD2’ is the bucketname i did put in config.php, but it seems Nextcloud don’t use the url i specified in the config file.

All the info used on the config.php files are tested and work when adding a External storage via the admin interface.

Config file: http://pastebin.com/PGR1tXFe
Thanks.

#2

Some news:

If call the ovh api whitout ssl (http://…) i have the following error message:
‘Guzzle\Http\Exception\CurlException: [curl] 7: Failed to connect to auth.cloud.ovh.net port 80: Connection refused [url] http://auth.cloud.ovh.net/v2.0/tokens

So it seems that nextcloud when i swap to https stop trying to call the auth url but instead use 127.0.0.1:8888. Any advice?

#3

@icewind …maybe you can help out? :thinking:

#4

@Jimmy_BERTRAND

I faced the same issue with OVH and fixed it by removing the line 'urlType'=> 'internal' in config.php (this setting is related to RackSpace provider)

My config.php looks like:

'objectstore' => array(
    'class' => 'OC\\Files\\ObjectStore\\Swift',
    'arguments' => array(
        'username' => 'OS_USERNAME',
        'password' => 'OS_PASSWORD',
        'bucket' => 'CONTAINER_NAME',
        'autocreate' => false,
        'region' => 'GRA3',
        'url' => 'https://auth.cloud.ovh.net/v2.0',
        'tenantName' => 'OS_TENANT_NAME',
        'serviceName' => 'swift',
    ),
),
1 Like