Stuck on update process. Step 5 is currently in process. Please reload this page later

Hi Wiggum23,

I was stuck on the same error for step 5. Under nc/updater/index.php i edited line 1338-1340 on mine and removed

		case 5:
			$updater->verifyIntegrity();
			break;

Removed this skipped the check and installed just fine. Let me know if this helps.

Sorry for responding late.

I searched around a bit today because there must be a reason for this error. There were some new information in another thread I tested.

I entered in the .htaccess (root directory, not the one under config)

php_value memory_limit 256M

Below the line

DO NOT CHANGE ANYTHING ABOVE THIS LINE

And now it worked fine.

Thanks for all your help.

3 Likes

Hi,

I am linking the only sollution that worked for me in a this situation when upgrading from 18.05 to 18.06 and I got stuck af step 5:

Credits go to @rahlquist

In short (my php version was 7.3)
/etc/php/7.3/cli/php.ini had -1 for memory limit, and it should stay that way
Returning the setting back to -1 this error went away.

https://help.nextclhttps://help.nextcloud.com/t/stuck-on-update-process-step-5-is-currently-in-process-please-reload-this-page-later/58371/6oud.com/t/allowed-memory-size-of-xxx-bytes-exhausted/39371/11

I was stuck at step 5 validation. I edited the hidden step file in …/nextcloud/updater-ocflfrurabky/.step from {“state”:“start”,“step”:5} to {“state”:“end”,“step”:4} to retry the verification and it worked just fine.

5 Likes

I ended up commenting the check for active step out of the file, and got my update running.

Hi @dshirk. For “years” I was looking for a solution to continue with my update. You gave me the final information I needed.

But for other reading this, two additional information:

  1. in my case I had to look into …/nextcloud/data/updater-oc5y20h2fvse (not just …/nextcloud/
    folder)

  2. a simple renaming of the file .step did the job too. Then my updater went through the whole process.

Thanks again. Hope my info do help others.

3 Likes

Hello.

Just seeing this problem now.

Attempted to upgrade from Nextcloud 18.0.10 -> Nextcloud 19.0.4
Used: sudo -u www-data php /var/www/nc/updater/updater.phar command

I successfully completed upgrades with this before. Now I am stuck on:

Nextcloud Updater - version: v18.0.9-8-g27dac77
Step 5 is currently in process. Please call this command later.

People suggest editing/removing .step file, but my Nextcloud folder does not even have one:

ls -LR /var/www/nc/ | grep step
from.nextstep.ser
gestep.htm
gestep.png
gestep.htm
gestep.png
gestep.htm
gestep.png
gestep.htm
gestep.png
gestep.htm
gestep.png
step-decay.md
step21.js
step21.js.map
updater-3-running-step.png
updater-4-failed-step.png
updater-cli-3-running-step.png
updater-cli-4-failed-step.png

Editing index.php and removing case 5 from the switch statement did not help.

Still stuck on upgrading to 19.

In my case the file (and the nextcloud installation) is not in /var/www/... but in /home/www/... . You might be looking in the wrong place.

Nope. All of my Web stuff is in a standard location: /var/www

Bad. :neutral_face: Out of ideas. I tried all the other things without success. Removing/renaming the .step file allowed me to finally update my 15.x nextcloud all the way up to 19.x. I am sure it is somewhere. Question is where…

Sad to see how this and other threads about this bug are totally ignored by the team. GitHub threads are closed as if it is not a bug. Not sure this can be used in a serious production environment with this approach.

Hi,
with every update (20.0.4 at the moment) I have the same problem. Stuck in step5, but there is no error given (field is empty). My virtual server has not very much PHP memory (128 MB), so maybe this is the problem, but this is only a guess, since no error message is given.
After some manual updates, I find it most convenient to skip the verification by chnanging the .steps file to:
{"state":"end","step":5}
However, I always have a bad feeling, fearing that the update ultimately might fail and I have to set up the whole thing from scratch.
It would be nice if the dev team got a look into this problem.
Regards

Hi,
there are two things - based on my experiences. My NextCloud is hosted at all-inkl.

  1. set php memory limit to 512M by editing .htaccess file:
    php_value memory_limit 512M

  2. delete old update leftovers which are placed in data directory. In my case this disturbing folder was called: [updater-oco7ek3xolkq]
    Just delete this folder and you are ready to run the updater.

Please feel free to share with us whether is worked for you as well.
Take care and stay healthy

15 Likes

I too just renamed it and everything went down smoothly :+1:

2 Likes

thank you - that did the trick for me!

Thank you! My NextCloud is hosted at all-inkl, too. I did:

  1. set php memory limit to 512M by adding to .htaccess file:
    'php_value memory_limit 512M`
  2. delete file .step in data/updater-…
  3. retry update => everything was fine
2 Likes

When running updater via CLI, you can raise the PHP Memory limit by setting a CLI Parameter like this:

php -d memory_limit=512M upgrader.phar

1 Like

I’m on a synology bare metal installation (php-7.2)
I’m trying to update 19.0.6 ->20.0.4
Deleting the folder nxtcld/data/updater-oco7ek3xolkq at least makes the stuck on step 5 -error go away and let’s me restart the update-process. The process then still always stucks on step 5:


  • Verifying integrity

Parsing response failed.
Show detailed response


However, after editing the “.htcaccess” file below the “DO NOT CHANGE ANYTHING ABOVE THIS LINE” -line the instance crashes with failure 500 and nextcloud is no longer accessible.
Removing the php_value memory_limit 512M-line makes it accessible again.
Are there other measures to raise the PHP-limit (I’ve also edited the @appstore/PHP7.2/usr/local/etc/php72/cli/php.ini but to no avail).

Today I got stuck on the #5 issues as well when trying to update from version 19 to 20.
I got it to work with a combinations of the suggestions in this thread:

  • Removed the .step file in the data/updater-xxxxxx folder

This got me able to retry the update, but kept giving the #5 error. Then I:

  • Removed the old V20 download in the data directory

  • Changed the php-memory limit to 512M under resource limits in /etc/php/7.2/cli/php.ini

  • Changed the php-memory limit to 512M under resource limits in /etc/php/7.2/fpm/php.ini

  • Added the php_value memory_limit 512M`in the .htaccess file in the nextcloud installation folder (/var/www/html/nextcloud for me):

  • On the command line restarted service: systemctl restart php7.2-fpm

With these changes also the error nextcloud threw regarding my memory limit was gone. I’ m not completely sure which of the last steps did the trick for me, my best guess is that is was the fpm setting. Setting the cli/php/ini setting back to -1 did not bring back the php memory error.

Hope this helps to those who did not yet managed to get the update running

Hi,
I have a similar issue, stuck of the step 5 of the upgrade…
I can not change toe mem limit of php, since it is only a rented webspace.
I don’t have any .step files in any nexcloud directories.

Any other suggestions please?
Thx!