Stuck on "deleting old files" / Update from to 16.X

The update got stuck on “Deleting old files”.
Apparently, this is a recurring issue, as others expereinced this, too.

Admittedly, I know very little of my nextcloud:
Nextcloud version :
Operating system and version : Hosted by Strato
Apache or nginx version : Dito…
(If anyone can point out where I can find those values, I can provide the info here)
PHP version : 7.2

Things I’ve tried:
Set all permissions to 755 (even to 777)
‘maintenance’ => true,
‘maintenance’ => false,
in config.php

No success, Still the same error:

  • Parsing response failed. Step 9 is currently in process. Please reload this page later.

I did reload the page - to no avail.

I even removed the “updater” folder manually, which led to a 404 error in the error message:

  • Parsing response failed. 404 Not Found

    Not Found

    The requested URL was not found on this server.

Soo … the question remains: what is left to do here?

Many thanks in advance and kind regards,

(note: I can access via FTP only, so unfortunately I cannot provide any linux commands or their results)

Here is my config.php, just in case:

$CONFIG = array (
  'instanceid' => 'occ72akcbxt4',
  'passwordsalt' => 'XXX',
  'secret' => 'XXX',
  'trusted_domains' => 
  array (
    0 => '',
  'datadirectory' => '/mnt/web021/e3/85/51320785/htdocs/path/to/my/nextcloud/data',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => 'XXX',
  'dbname' => 'XXX',
  'dbhost' => '',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'XXX',
  'dbpassword' => 'XXX',
  'installed' => true,
  'maintenance' => false,
  'updater.secret' => 'XXX',

I just tried the following:

  • create a backup of the files
  • overwrite everything with the files from the current edition

This just led to the message “CAN_INSTALL is missing”.
But, no, I do NOT want to re install the whole cloud (and thus empty my database)
I just want to update.
So - what do I do here?

Try to check this out Update to 13 fails - core/shipped.json is not available - #4 by gas85 it is failed on the same step.

Don’t overwrite code, you will keep old files that don’t exist in the new version. You can do the manual upgrade, which is to delete the old code (just keep the data and the config folder), then put the new code and when you open Nextcloud in the Browser, it should let you run the upgrade. If you have a shell access, you can run the upgrade command from there (occ upgrade) where you don’t risk to run in timeouts.

right …
now it says:
Exception: Updates between multiple major versions and downgrades are unsupported.

Apparently, I need to upgrade to 16.X
Then to 17.X
Then to 18.X
Then to 19.X
Then to 20.X

And all of this manually as described above …

I’ll report back, when it’s done :slight_smile:

1 Like

The site doesn’t work anymore …

I think, I’ll be better off just throwing my cloud away, and install V20.X and upload everything anew …

Sort of bullshit, but - hey - welcome to Linux: If it doesn’t work, if you have to sink your teeth into tons of manualpages only to decipher some obscure commands you have to send, then you know it’s a Linux product you are toying with …

frustration and anger level increases


Well, plain Linux sytems are much better than hosting environments for Nextcloud.

Internal Server Error

The server encountered an internal error and was unable to complete your request.
Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.
More details can be found in the server log.

That’s why … And, no, there are no “technical details below” given!
I don’t have access to the server log: it’s a hosted environment. And it’s all I’ve got.
Having to fall back to a solution I have no access to is very helpful. Thanks.

Also: I get the above message after uploading the files for the V20 in an attempt to install a new version … yay …

Right … installing the latest version helped.

I’ll keep that in mind… thanks …

That’s for sure… You always need to go over all of major versions… Sorry, didn’t noticed that you are on 15…