Stuck on 21.0.4, even though 23.x is available

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 21.0.4
Operating system and version (eg, Ubuntu 20.04): Docker
Apache or nginx version (eg, Apache 2.4.25): ?
PHP version (eg, 7.4): 7.4.26

The issue you are facing:
The Settings in Nextcloud show that there’s an update available, 21.0.7 (from where I’ll leapfrog all the way to version 23, I assume). But clicking “Open updater” shows “No update available.”

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Have version 21.0.4.
  2. Go to Settings > Overview and see that there’s an update.
  3. Click on “Open updater” and get told that there’s no update, even though you’re apparently 2 major versions and many minor versions behind.

For Docker installations you have to update/pull the image to/with the desired version. The internal updater doesn’t work. Keep in mind that you should upgrade through all major versions.

So, first update to nextcloud:22 and then to nextcloud:23.

You are probably using nextcloud:21 atm.

It’s actually the Linuxserver Docker container, so it relies on the internal updater. Updating the docker image does nothing. Seems there’s a disconnect between the Settings page update checker (update available), and the internal update checker (no update available). There’s a bunch of threads here of people experiencing the same thing, but it seems to “magically” work for them the next day with no indication of why it wasn’t working from Nextcloud. Mine hasn’t worked for weeks.

Why the internal update checker claims there’s no update available is the question.

Screen Shot 2022-01-22 at 3.53.34 PM
vs. when you actually click on “Open updater”:

Ok, I thought you were using the official Docker release :slight_smile:

Have you tried to switch the update channel to “beta” and see what’s offered then?

I see the same behaviour on multiple non-Docker instances. They show an update to be available, but once you start the updater you get “No update available.”. This is for 21.0.5 trying to update to 21.0.7 and 21.0.7 trying to update to 22.2.3.

So I guess it’s probably a temporary issue with the Nextcloud update servers at the moment. I’ll retry Monday evening.

No difference on Beta unfortunately

Hi @brnog892

I’ve just received a message saying that the update server could not be reached in the last 3 days.
There is already a github issue that I can confirm Update server returns 500 ISE · Issue #698 · nextcloud/updater_server · GitHub

Best, Bernd

1 Like

Update just worked. Got a “Nextcloud couldn’t reach the update server in 3 days” notification. A few hours later, got a notification about an update at last and was able to update normally. Thanks to @lebernd I was able to understand it was a Nextcloud server issue and nothing on my end, and the solution was only to wait, as those earlier posters found out unwittingly.