Stuck in Update-Process - Updating NextCloud 18.0.4 to 18.0.9 fails at step "Move new files in place"


Nextcloud version (eg, 18.0.2): 18.0.4
Operating system and version (eg, Ubuntu 20.04): DSM 6.2.3-25426 Update 2
Apache or nginx version (eg, Apache 2.4.25): Apache 2.4.43
PHP version (eg, 7.1): 7.2

The issue you are facing:

Updating NextCloud 18.0.4 to 18.0.9 using the the wefails at thestep “Move new files in place”
Error Message displayed: “Could not mkdir /volume1/web/updater/…/3rdparty/icewind/searchdav”

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

update is stuck - retry update does not help!

The output of your Nextcloud log in Admin > Logging:

=> cannot access it

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => 'oc2dkj44usa8',
  'passwordsalt' => 'xyxyxy',
  'secret' => 'tgdfgdfvcr',
  'trusted_domains' => 
  array (
    0 => 'mydomain',
  'datadirectory' => '/volume1/NextCloud',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => 'https://mydomain',
  'dbname' => 'nextcloud',
  'dbhost' => '',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'oc_Admin',
  'dbpassword' => 'xxxxxxxxxxxxxxxxxxxxx',
  'installed' => true,
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'mail_smtpmode' => 'smtp',
  'mail_smtpsecure' => 'ssl',
  'mail_sendmailmode' => 'smtp',
  'mail_from_address' => 'mail',
  'mail_domain' => 'mydomain',
  'mail_smtpauth' => 1,
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtphost' => '',
  'mail_smtpport' => '465',
  'mail_smtpname' => 'mail@mydomain',
  'mail_smtppassword' => 'mypasswword',
  '' => 'stable',
  'updater.secret' => '$2y$10$N9w23zCbiAtWSPgic5R1beOFxp.6c6wvRL6ZSXWvtFr/A9C92junO',
  'maintenance' => true,
  'theme' => '',
  'loglevel' => 2,

Dear all,

apart from the problem described, I am now fully stuck in the update process.
I can’t access the updater any longer.

See screenshot below - I need the unhashed value of the updater.secret from the config file. but I don’t understand how to get the unhashed value. Alternatively the updater should be accessible via the Nextcloud admin screen, but I can’t login anymore on my nextcloud server (as admin), as get only the error message: update in process.

Can some explain me how can get access again - at least to the updater (and advise on my original problem would also be great.

Thanks in advance!!!

1 Like

exact same problem here

same problem here. :frowning: any of ou have any luck solving this.

I had the same problem here. I ran the command specified (the one that appears on you screenshot) to generate the plain secret, but it did’t work. And even worse, when I ran occ upgrade command, it informed that upgrade was successful, but every time I tried to access via browser, I receive an “Update in process.” message.

Then I found this solution: It’s for an old Nextcloud version, but I just did it and worked perfectly. Basically it indicates to manually copy the download files from upgrade to Nextcloud directory (and set permissions properly).

But there was a trick. At least in my setup, the upgrade files were on my Nextcloud data directory and not on my Nextcloud install directory. Hope this help!

1 Like