Stuck in maintenance mode when upgrading

I installed nextcloud in May 2016 using whatever. When version was current then. I didn’t use it until January 2017 when I started doing one file sync operation a month. It worked fine for four months. When I tried at the end of May it gave an error. I looked at the screen and saw that it had gone into maintenance mode pending an upgrade to 10.0.5. I don’t actually care what version I use if the file sync works but there didn’t seem to be any other option than to upgrade. OK, so I pushed the upgrade option and got a please wait message. After a few minutes I got a message that an error had occurred. There was a pulldown arrow for details. I pulled it down and saw a one-liner saying that an error had occurred. No other information.

So what are my options here?


Did you use the web updater? It’s unclear to me how your update initiated. If you did the update via the web updater, I would disable maintenance mode

sudo -u www-data php occ maintenance:mode --off

be sure to run that from your nextcloud instance’s root directory, and then retry the updater if you did your update via the web interface.

How do i know where the nextcloud instances root directory is? Sorry im totaly new in this stuff.
I have a nextcloudpi instalation and I tried to update nextcloud with the web interface and now im stuck in maintenance mode. So only terminal. no GUI
I tried your command in many differend directorys but it always gives me “Could not open input file: occ”.
I found a directory called nextcloud in /var/www/nextcloud but it says “-bash: cd: nextcloud: Permission denied” when i try navigaitng there.

Hi voldemort,

You are correct to be in the /var/www/nextcloud directory on Nextcloudpi. For your instance you may be better served typing the full path to the location of “occ”, so it will look like this:

sudo -u www-data php /var/www/nextcloud/occ maintenance:mode --off

1 Like

@stratacast is right

does Nextcloud come up ok after that? I tested the upgrade to 12.0.3 and it worked, but I was on a clean image with no apps or anything.

After auto upgrade on NextcloudPlus my instance was stuck in maintenance mode too.

Should I bet temporarily disabling auto updates?

Checked version after running sudo -u www-data php /var/www/nextcloud/occ maintenance:mode --off

I’m running on:

[ nc-update-nextcloud ]
Current Nextcloud version
Available Nextcloud version 13.0.2
Nothing to update

Thanks for guidance in advance

Hi @johnstuff what do you mean exactly by autoupgrade? do you have any logs (like /var/log/ncp.log)?

I haven’t had a single bad report on any of the autoupdate/upgrade mechanisms so far

Thank you! Solved this problem for me!