Stream Video from Nextcloud. slowly


I would share an Video to my friends. 500 MB Size and 2,7k Resolution.The download works good but not the Playback.

What can i do to make it playable?

I tried to enable output_buffering in php, but this won’t work

It is possible that either you or they don’t have enough bandwidth to do it. Your outbound connection and their inbound connection have to both be fast enough to deliver the data to their player before it’s needed for playback. At 2.7k resolution, I’m guessing that 500MB file is fairly short in duration, and in order to stream it, the connections have to be able to deliver the entire file in the time it takes to play it. Also, their browser has to have a player capable of decoding the information. It is possible their browser doesn’t support whatever format the video is, but a different program on their computer does, which is why it works when downloaded.

Unfortunately, streaming has a lot of moving parts, and services like YouTube have mastered them so well that most people don’t realize just how many there are. YouTube for example will adapt the bitrate up or down to get the best quality for the watcher with their available bandwidth; if their connection can’t support 1080, it will downgrade to 720, 480, 360, 240, and even 144 until it finds a resolution their connection can reliably support. On top of that, all uploaded videos are converted by their server to web-compliant formats for distribution.

Certainly it would be possible to add this kind of functionality into NextCloud, and maybe someone already has (I’m new here,) but know that it will take a lot of CPU resources during conversion, and a lot of space for the different resolutions, which have to be prepared in advance, and a whole new app to add this system. It’s not as simple as enabling an option.

1 Like

Thanks for your answer. I uploaded the Video again with Full HD resolution. And it loaded faster. Nextcloud is hosted on an Dedicated Server by an big german provider. (Hetzner) Bandwith is only an Problem by the Internet Provider.

1 Like

I’m glad I was able to help you, glad you found a solution, and glad you didn’t TL;DR on my long reply before you got enough info to solve the issue. :open_mouth: I actually was going to suggest trying a lower video resolution and then forgot, but you deduced that you might solve the problem that way from what I did say. Have a great day!