Strange behavior during upload big files

Hi, community :slight_smile:
I came across an incomprehensible phenomenon. At least for me.
I have virtualbox installed nextcloud
Virtual hard drive size 8 Gb - operating system
Virtual hard drive size 250Gb - nextcloud data
Nextcloud version (eg, 11.0.2):
Operating system and version (eg, Ubuntu 16.04.02):
Apache or nginx version (eg, Apache 2.4.18):
PHP version (eg, 7.0):

During uploading big files (1.5 G and more) The download process is abruptly interrupted by a server message "Bad request"
Then i have tried to upload files 500M 700M 1400M - everything is fine.
But then i tried file with size 1500M - ups … errror - Bad Request.

Accidentally found the cause of this problem:
watch df -h showed me what’s happening during uploading file.
First The recording process takes place on the system hard disk, after that file moves to second disk. If free space on system disk is less than file size - that is no problems.

What could be the problem ? :confused:

Maybe try some of the steps in this thread

Problem solved. I just resize system disk from 8 Gb to 20 Gb.
Now i am able to upload files up to 10 Gb and larger such as movies etc.
This is output of df -h
udev 981M 0 981M 0% /dev
tmpfs 201M 3,2M 197M 2% /run
/dev/sda1 18G 4,4G 13G 27% /
tmpfs 1001M 0 1001M 0% /dev/shm
tmpfs 5,0M 0 5,0M 0% /run/lock
tmpfs 1001M 0 1001M 0% /sys/fs/cgroup
/dev/sdb1 246G 15G 220G 7% /mnt/ncdata
tmpfs 201M 0 201M 0% /run/user/1000
How we can see /dev/sda1 have 13G of free space. This is the maximum size of uploading file.

Found another solution.

upload_tmp_dir = /var/www/owncloud/data/upload-tmp
I just created temp directory on my data disk.
Now during uploading files system disk is not used.

Hi, everyone

I am newbie on nextcloud, I installed invention portal with nextcloud on VM, the hard drive provisioned for this vm machine is 1000GB, but now I can’t login to nextcloud, vm show me 40GB used, but when I check I console df -h I see that /dev/mapper/vg_ucs-root use 100% maybe it could be a problem.

Anyone can help me?

i know this is old but you’re actually a newbie on linux. you filled up your / partition. the system halts if you do that.