Standard share settings (by admin) doesn't work

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 18.0.2): 19.0.1
Operating system and version (eg, Ubuntu 20.04): Debian 10
Apache or nginx version (eg, Apache 2.4.25): ?
PHP version (eg, 7.1): 7.3.19

The issue you are facing:
When i configurate as admin the standart share rights (update, change, delete, share) in administration on the server, then this values are not active when a user share a dire or a file.
E.g. I set as standart-right, when a user create a share, that the receiver has no possibilities zu create or change or delete the content of the share. But, independently from my settigs, the user has ALL right to to with the content what he want. When i show the rights on the share he has full access - no matter what i have configurate on the server.
In the DB, under oc_appconfig are all config values correct:
|core|shareapi_default_permission_cancreate|no|
|core|shareapi_default_permission_candelete|no|
|core|shareapi_default_permission_canshare|no|
|core|shareapi_default_permission_canupdate|no|
|core|shareapi_default_permissions|1|

But after i make a share, the default permissions are not “1” rather “31”!

Is this the first time you’ve seen this error? (Y/N):
i see this on 2 installations from 19.0.1
Steps to replicate it:

  1. configure the standart share permissions (/index.php/settings/admin/sharing)
  2. share a dir or a file
  3. look et the permissions have the reciever

The output of your Nextcloud log in Admin > Logging:

PASTE HERE

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

PASTE HERE

The output of your Apache/nginx/system log in /var/log/____:

PASTE HERE

Have your really set the correct permissions. Can you post the settings and an example with sharing (sender, receiver, …)?

Hy devnull,
yes i am sure, that we have set the permissions correctly on the Server (see screenshot, but in german :wink:

Here are the share from a user to another (without set any permissions):

Thanks for your help!
Tom

Here the by the user:


The user can “umbenennen” (rename), “Datei löschen” (File delete)

My settings. I think you must set “Standardberechtigungen für das Teilen”:

Hy devnull,

da du eine deutsche Version benutzt, nehme ich jetzt mal an du sprichst deutsch :wink:
Wir sind eine Schule und standartmässig sollen die Schüler, wenn der Lehrer mit einer Klasse einen Ordner oder Dateien teilt, keine Rechte haben die Daten zu ändern oder zu löschen - deshalb haben wir, wie in unser vorhergehenden Version (16.0.9), bei den Standartberechtigungen keine “Haken” gesetzt. D.h. die Schüler können, wenn der Lehrer das nicht explizit setzt, weder ändern noch umbenennen oder gar löschen. Dies wäre für unseren Fall absolut korerekt. (Sonst kann ein Schüler die vom Lehrer geteilten Daten löschen oder ändern - für eine Schule ziemlich blöd… :wink:

Gruss, Tom

Ok dann habe ich dein Problem falsch verstanden.

Auch habe ich die globalen Einstellungen (die wir beide unterschiedlich gepostet haben) so verstanden, dass sie notwendige Vorraussetzungen sind, damit es überhaupt funktioniert. Denn bei mir ist es so, dass eine neue Freigabe defaultmäßig immer “Schreibgeschützt” erlaubt wird und das obwohl ich alles in der Systemkonfiguration angeklickt habe. Ich denke es steht in keinen Zusammenhang.

Dann seid ihr ja etwas zurück. Ich kann nur von ehemals 18 und nun 19 berichten. Und wie gesagt bei mir wird “Schreibgeschützt” angezeigt.

Es gibt verschiedene Möglichkeiten zu teilen. Mit meiner Version teilen wir über das Verzeichnis (LDAP) einen Ordner/Datei, welche dann in deinem Stammverzeichnis der Cloud als geteilt angezeigt wird, deine gepostete Möglichkeit ist mittels direktem Link. Wir teilen über folgendes Feld:

Oh ja. Das ist dann anders. Bei mir ist auch alles angeklickt egal ob ich deine oder meine Einstellungen bzgl. Teilen eintrage. ich verwende Nextcloud 19.0.1 . Dann ist es vielleicht wirklich ein Bug seit Version 18 oder 19. Weiß jemand mehr?

Also in Version 16 hat das einwandfrei funktioniert. Nach dem Upgrade auf 19.0.1 ist uns irgendwann aufgefallen, dass die Rechte - egal was man vergibt - nicht auf die geteilten Inhalte angewendet wird. In der nextcloud DB in der Tabelle “oc_appconfig” werden unter
|core|shareapi_default_permission_cancreate |no|
|core|shareapi_default_permission_candelete |no|
|core|shareapi_default_permission_canshare |no|
|core|shareapi_default_permission_canupdate |no|
|core|shareapi_default_permissions |1|
die Rechte je nach “Häkchen” zwar geändert, jedoch werden diese Werte aktuell wohl ignoriert, resp. nicht korrekt geladen… :frowning:

Ok. Ich habe mal einen Issue auf Github eingestellt.

nach deutsch verschoben aufgrund der deutschen Antworten.
Was ich hier persönlich schade finde, denn das wäre sicher interessant für den einen oder anderen internationalen Forumisten…:frowning:

Sorry. Aber vielleicht findet der eine oder andere englischprechende Anwender diesen Beitrag über eine Suchmaschine.

@JimmyKater
Kannst du den Fehler nachvollziehen? Vielleicht gibt es auch schon andere Issues. Aber bei meiner Suche konnte ich so schnell nichts finden.

seems to be fixed with 19.0.2

2 Likes

i can confirm the fix in 19.0.2!

I have the same issue with Nextcloud 20.0.9 right now, at least for link sharing.
Is it fine to write here or should I better open a new ticket?

I have the same issue with version 23.0.0. If I share a link to external with write permission - it doesn’t work. There are no write permissions and read only mode.

you can see that the initial github issue seems to be open, still… so why not updating it with your setup and informations?