SSL install not working


First I’d like to say Nextcloud is a great product so thanks for that.

I do have a problem though (I’m a complete noob to SSL), I’ve installed Nextcloud via snap on Ubuntu server 18.04 let’s, ive also installed Ubuntu-desktop gui.

I can install Nextcloud snap no problem and set the trusted domain for internal network, all works fine.

I can also access remotely on web (but not iOS app) when I give my external iPad as a trusted domain.

My problem starts when I want to use the app it asks for a ssl connection, I have tried certitude but it can’t accept an external ip it wants a text domain ( I have also tried letsencrypt but still no success.

Can anyone point me in the correct direction.


what was the problem with let’s encrypt? this is usually the best way to handle this

I use certbot for an easy setup

Hi thanks for your reply but I think I’ve been able to resolve the problem. I had my router port forward from a none standard numbers letsencrypt and certbot obviously don’t like this.
I’ve now reset to the standard port numbers and all seems well.


ah right, certbot needs ports 80 and 443 to be open for that. but you can use reverse proxy to forward from them to any port you still want to use other ports