SQL problems of some kind? novice in over my head

Nextcloud version:
Operating system and version: Ubuntu 16.04.2
Apache or nginx version: Apache/2.4.18

Trying to address an error I’ve had for several days. Client upload failing on certain files, which seem “stuck” - unable to delete through client or web interface. Tried this to no avail: https://help.nextcloud.com/t/file-is-locked-how-to-unlock/1883/9

Ran sudo -u www-data php occ files:scan —all and got the following output: https://pastebin.com/YfERsfpM
Ran it again and got this: pastebin.com/sXQyt8qp (apologies, it won’t let me add more than 2 links)

Have already tried unlocking files as described in the post linked above, the command seemed to execute but had no apparent effect. I’m stuck, please help!

The output of your Nextcloud log in Admin > Logging:
OC\Encryption\Exceptions\DecryptionFailedException: Can not decrypt this file, probably this is a shared file. Please ask the file owner to reshare the file with you. Repeated many times

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):
$CONFIG = array (
'instanceid' => '************',
'passwordsalt' => '************',
'secret' => '************ array (
0 => '************',
1 => '************',
'datadirectory' => '/mnt/volume-fra1-01-part1/nextcloud/data',
'overwrite.cli.url' => 'https://************/nextcloud',
'dbtype' => 'mysql',
'version' => '',
'dbname' => 'nextcloud',
'dbhost' => 'localhost',
'dbport' => '',
'dbtableprefix' => 'oc_',
'dbuser' => 'nextcloud',
'dbpassword' => '************',
'logtimezone' => 'UTC',
'installed' => true,

"MySQL server has gone away"
Did you try rebooting your whole server?

Many times ;-;

Can you check the status of mysql?

sudo service mysql status

Looks normal: https://pastebin.com/61WHnWME

Are you using the Nextcloud snap? I’m seeing this in the bug tracker, maybe there’s some helpful info there. Otherwise I would recommend posting an issue on the bug tracker (either in the nextcloud-snap repository if that’s what you’re using, or the server repository if you installed from the package).