Spreed Videocall-App: Kein Bild bzw. schwarzes Bild

Hallo zusammen,
ich nutze gern und häufig die die Spreed-App (nicht Spreed.me). Dies klappt von innerhalb eines LAN/WLan-Netzes also auch von einem LAN/WLAN-Netz in ein anderes recht gut, nachdem hierfür mindestens eine Seite statt Firefox Chrome bzw. den Iridium-Browser nutzt (mit Firefox zu Firefox hat eine Seite auch nur “schwarz gesehen”. Auch mit Mobilgeräten klappt es dann. ABER:

Wenn eine Seite oder auch Beide sich nicht im LAN/WLAN-Netz befinden sodern ein Mobilfunknetz verwenden, wird zwar die Verbindung hergestellt, aber das Fenster wird schwarz.

Dieses Thema wurde im englischsprachigen Forum auch schon diskutiert, aber ich bin daraus nicht schlau geworden - im Übrigen ist Englisch nicht meine Muttersprache.

Es muss wohl irgendwas mit dem STUN- und/oder dem TURN-Server zu tun haben. Ich habe hier keine Einstellungen verändert, beim STUN-Server steht “stun.nextcloud.com:443”, beim TURN-Server nichts.
Da ich Nextcloud auf bei All-Inkl.com laufen habe, kann ich einen TURN-Server auch nicht installieren - abgesehen davon, dass ich davon keine Ahnung habe.

Was kann ich nun tun um mein Problem zu beheben?

Sorry wenn ich an dieser Stelle mal meine eigene Frage pushe, hat denn keiner eine Idee? Kann eigentlich nicht sein dass ich der Einzige bin.

Hei, ich habe dasselbe Problem. Es funktioniert, wenn ich einen anderen Browser nutze.
Microsoft Edge schwarz, bei Firefox wird das Video abgespielt.

Danke für deine Antwort. - Du hast Recht: Man sollte schon darauf achten dass der verwendete Browser WebRTC anständig unterstützt. - Und das tut der Firefox.
Mit meinem Problem hat das allerdings recht wenig zu tun.
Ich habe mittlerweile einen TURN-Server installiert (auf einem separatem virtuellen Server, hierfür habe ich ‘coturn’ verwendet) und nun klappt es ohne schwarzem Bildschirm auch in Mobilfunknetze.