Spreed/talk integrtiy check fails for one file

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 25.0.2
Operating system and version (eg, Ubuntu 20.04): Ubuntu 22.04 LTS
Apache or nginx version (eg, Apache 2.4.25): Apache 2.4.52
PHP version (eg, 7.4): 8.1

The issue you are facing:
- expected: 842c31db32c2712c63a4f4d7438c4b6d4d3b8a661fa11c86371280789be8b07f48c26018e808797ad93455e2519e0b1c3761b3baa8f9029243b931c2faf53a77
- current: 8dce2655d3a6dd259f7a6e9a6f9d8efe99b0b42bf14562fdce6c67be9cfe26e4617766c6454da921b47c3c06599bb51a767af77ac0ed5f03e52c696db3102617

Integrity check fails for a single JS file of Talk app

In other apps - when not part of the core package - I just removed the app and added it again using the GUI and the issue was fixed. Here I cannot remove the app, so I needs to replace the file, but I cannot find the file.
This is not a critical issue, as there is no technical issues at all. I just has this integritycheck failing, and I do not like to have untrusted files.

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Upgrade Nextcloud to latest release

The output of your Nextcloud log in Admin > Logging:

Nothing relevant.

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

Not really relevant

The output of your Apache/nginx/system log in /var/log/____:

Not really relevant


Okay I solved it same way. I could do excactly that: Deactivate and remove, download and activate and it was solved. This is closed. :slight_smile: