Spinning wheel on top of files

There is a spinning wheel in the area above the recent files in the files tab.

Nextcloud version (eg, 18.0.2): 18.0.4
Operating system and version (eg, Ubuntu 20.04): Lubuntu 20.04
Apache or nginx version (eg, Apache 2.4.25): nginx/1.17.10 (Ubuntu)
PHP version (eg, 7.1): 7.4

The issue you are facing:
I just set up a functioning nextcloud instance, but i see a spinning wheel in the area above the recently edited files.
I ran a full file scan with occ command and still the spinning wheel.
The overview shows no warnings or issues.
Otherwise the functionality is fine.
There is no spinning wheel on any other app.

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. set up working nextcloud
  2. log in as administrator
  3. open the files tab

The output of your Nextcloud log in Admin > Logging:
I get the following message every few minutes

[PHP] Error: Trying to access array offset on value of type null at /usr/share/nginx/nextcloud/3rdparty/leafo/scssphp/src/Compiler.php#5230

GET /settings/user
from 192.168.1.1 by admin at 2020-05-12T16:53:06+00:00

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => 'ocoqjbaawzym',
  'passwordsalt' => 'mfrJKzgVaj0+3lY0XmC8h6t595p0jN',
  'secret' => 'NMnSts3CJlKHuhIr7Zg3eNnQPkypkiE9pI9w5pxwbzL8O+AW',
  'trusted_domains' => 
  array (
    0 => 'www.dysoncloud.net',
  ),
  'datadirectory' => '/usr/share/nginx/nextcloud-data',
  'dbtype' => 'mysql',
  'version' => '18.0.4.2',
  'overwrite.cli.url' =>
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost:3306',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'nextclouduser',
  'dbpassword' => 
  'installed' => true,
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'mail_from_address' =>
  'mail_smtpmode' => 'smtp',
  'mail_sendmailmode' => 'smtp',
  'mail_domain' => 'startmail.com',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpauth' => 1,
  'mail_smtphost' => 
  'mail_smtpport' => '465',
  'mail_smtpname' => 
  'mail_smtppassword' => '9vn3ec2bc0tjj0xc',
  'mail_smtpsecure' => 'ssl',
);

The output of your Apache/nginx/system log in /var/log/____:

2020/05/11 21:09:07 [notice] 56491#56491: signal process started
2020/05/11 21:09:54 [crit] 56492#56492: *3 connect() to unix:/run/php/php7.2-fpm.sock failed (2: No such file o>
2020/05/11 21:09:58 [crit] 56492#56492: *5 connect() to unix:/run/php/php7.2-fpm.sock failed (2: No such file o>
2020/05/11 21:10:35 [notice] 56756#56756: signal process started
2020/05/11 21:21:03 [emerg] 57106#57106: open() "/etc/letsencrypt/options-ssl-nginx.conf" failed (2: No such fi>
2020/05/11 21:25:22 [notice] 57152#57152: signal process started
2020/05/11 21:36:47 [notice] 59735#59735: signal process started
2020/05/11 21:36:49 [notice] 59760#59760: signal process started
2020/05/12 08:32:21 [notice] 2448#2448: signal process started
2020/05/12 08:32:23 [notice] 2457#2457: signal process started
2020/05/12 08:32:26 [notice] 2469#2469: signal process started
2020/05/12 08:32:27 [notice] 2478#2478: signal process started
2020/05/12 08:35:28 [notice] 2593#2593: signal process started
2020/05/12 08:49:47 [notice] 3618#3618: signal process started
2020/05/12 09:47:29 [notice] 7851#7851: signal process started
2020/05/12 09:52:40 [notice] 9783#9783: signal process started
2020/05/12 11:34:25 [notice] 72128#72128: signal process started

I had the same problem with a newly setup Nextcloud 18.0.4.

It seems to be a bug in the text app. Disabling the “show richt Workspace” option in the lower left settings from the app files view worked for me.

( Creating an readme.md text file also solves this by displaying the content of this file /sometimes/ )

Thanks
Disabling show rich workspaces did the trick.
Creating a .md file, not so much.

1 Like

Thank you. Disabling Rich Workspaces also solved the issue for me in Nextcloud 18.04

This isn’t a fix at all. Rich Workspaces are extremely useful and we store a lot of notes on those. It’s a bug with the latest update, as before folders that didn’t have a rich workspace (Readme.md file) just showed an option to create a workspace. Instead, there’s now an infinite loading screen and the only way to add a rich workspace is to manually create a file titled readme.md. Additionally, existing Rich Workspaces take much longer to load with the newest update. Something got seriously broken in RW by 18.04.

1 Like

We are still looking for a way to reproduce those endless spinners.

1 Like

Update: Creating a Readme.md file did work, after refreshing the page. But creating a Readme.md file in each directory is not a solution.

Commenting out the following lines in /etc/nginx/conf.d/nextcloud.conf

error_page 403 /core/templates/403.php;
error_page 404 /core/templates/404.php;

Did the trick.
After this edit of nextcloud.conf the rich workspace dialogue loads on the top of the files page in all directories with, or without, a Readme.md file present.