Some jobs haven’t been executed since 29 days ago

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 24.0.4
Operating system and version (eg, Ubuntu 20.04): Debian GNU/Linux 11 (bullseye)
Apache or nginx version (eg, Apache 2.4.25): replace me
PHP version (eg, 7.4): 8.0.21

The issue you are facing:
Hello!

I have Nextcloud 24.0.4 running on a docker container and I’m getting this “Some jobs haven’t been executed since 29 days ago. Please consider increasing the execution frequency.” message.

And now my server seems to be all buggy and started getting ‘‘Server not found’’ while trying to upload files.

I read I need to set up a cron job to run the cron.php file, but I can’t even find cron installed in the Nextcloud docker container.

As a workaround, I tried to install and set up uptime-kuma to ping the http://192.168.15.36:8082/cron.php link. Even though uptime-kuma receives a response from Nextcloud, it does not seem to be running the cron job.

Is this the first time you’ve seen this error? : Yes

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
  'htaccess.RewriteBase' => '/',
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'apps_paths' => 
  array (
    0 => 
    array (
      'path' => '/var/www/html/apps',
      'url' => '/apps',
      'writable' => false,
    ),
    1 => 
    array (
      'path' => '/var/www/html/custom_apps',
      'url' => '/custom_apps',
      'writable' => true,
    ),
  ),
  'instanceid' => 'ocwkf9bgmxlg',
  'passwordsalt' => '783xd74W3ndWQhSgx92RbtlU78+O/p',
  'secret' => 'Trh0a99UuHUerKtEolULEfKPPLug3wBln2fFzBau0tLckoFI',
  'trusted_domains' => 
  array (
    0 => 'nasty.local:8082',
    1 => '192.168.15.36:8082',
),
  'datadirectory' => '/var/www/html/data',
  'dbtype' => 'mysql',
  'version' => '24.0.4.1',
  'overwrite.cli.url' => 'http://nasty.local:8082',
  'dbname' => 'nextcloud',
  'dbhost' => '192.168.15.36:3306',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'nextcloud',
  'dbpassword' => '9517',
  'installed' => true,
  'mail_smtpmode' => 'smtp',
  'mail_smtpsecure' => 'tls',
  'mail_smtphost' => 'smtp-mail.outlook.com',
  'mail_smtpport' => '587',
  'mail_sendmailmode' => 'smtp',
  'mail_from_address' => 'filipe',
  'mail_domain' => 'hotmail.com',
  'mail_smtpauth' => 1,
  'mail_smtpname' => 'filipe@hotmail.com',
  'mail_smtppassword' => '',
  'updater.secret' => '$2y$10$iPwgcDslIQj.pdLBAYmAqep0boSVLbBl04U8ZII8.5FrzznN7ZZr.',
  'loglevel' => 2,
  'maintenance' => false,
  'default_phone_region' => 'US',
  'enable_previews' => true,
);

Can I get some help, please? :smiley:

I tried running the following on the HOST machine:

docker exec -d NextCloud su -u 33 php -f /var/www/html/cron.php

But still no joy

Docker setup required another another Nextcloud container running cron as startup argument see following threads, this should include references and useful discussions

take a look on official docs as well

1 Like

Thank you for your quick reply, @wwe

I realized I was running the wrong script from my HOST machine.

It should be:

docker exec -u www-data NextCloud  php -f /var/www/html/cron.php

After adding it to my Host’s crontab, it worked perfectly!

My crontab now is like this:

 */5 * * * * docker exec -u www-data NextCloud  php -f /var/www/html/cron.php