Some External Storages showing empty listings in NextCloud

I have a few External Storages set up and until recently they all worked fine.
Now however when I open two of them, nothing is listed when opening it.
The External Storages are all SFTP.
I can still access sub folders and files directly though so while going to the generaldata External Storage displays nothing, if I go to generaldata/Photos then I can see the contents the Photos sub directory just fine.
The NextCloud client that was already configured to use the sub folders for syncing so the syncing still works.
I currently have NextCloud 14, Apache 2.4.33, PHP 7.1.18 and use Gentoo Linux.
A few days ago when I noticed this problem I had NextCloud 13.
I thought upgrading might fix this problem but it did not.

And that root directory definitely has some data still and the files in there are not hidden files, right?
Permission changes on the FTP server?
Any other changes you made?
Anything in the logs or in the browser console?

Yes the directory does have data in it and only a few items are hidden, most are not.
I also have the Show Hidden option in NextCloud turned on.

SSH Server and no.

No, the logs don’t seem to show anything.

I just tried using a standalone SFTP client and it was able to show the directory without any problems.

Seem to or don’t? :slight_smile:
We need at least something to know where to aim at. While we can’t access your system, please try to provide some more information regarding your debug and analysis steps, logs and your configuration (of your external storage in NC):

Maybe system logs (if it’s ssh connection), web server logs, nextcloud logs (probably increase log level to debug) and browser console output.

I decided to try messing with the configuration of the External Storages and solved this issue.
For one of the External Storage ones, I had to delete the External Storage configuration and recreate it using RSA Public Key 4048 instead of RSA Public Key 1024 and it worked.
For the other External Storage ones, I just changed the configuration from RSA Public Key 1024 to RSA Public Key 4048 and it worked.
I don’t know why this worked though.

1 Like

Maybe this was due to an update of SSH on your server and a more restrictive configuration? Maybe a stupid guess.
Nonetheless I’m glad it’s solved for you now :slight_smile: