Some encrypted (E2EE) directories are not accessible anymore

Dear Nextcloud Community,

In summary, I face the following disaster:

I’m using macOS 14.4.1 with the Nextcloud client 3.12.1 for a Nextcloud instance. For more details about the Nextcloud instance,
I could ask our admins.

I have end-to-end encryption enabled. In particular, I have an encrypted directory called HOME (~8 GB) with files and subdirectories.
Everything worked well for about 3 months.

Today, I noticed that most of the files and directories in HOME are renamed to something that looks like a hash and I cannot access these directories and files anymore. I could provide screenshots showing this in the client.

Now, almost all of my data in HOME are inaccessible and seem to be lost.

I reach out to you and hope that you could help me restore access to my data.

Thank you very much in advance,

Have you changed the version recently, so you could say it was from version xxx that it started to fail?

In 3.12.2 there were bug fixes for E2E. So I’d perhaps try with a more recent version of the client.

If that does not help, check the logfiles, are there any messages regarding the end to end encryption? You still know your keyword for the encryption, you could try to use it via a different client to access it (different desktop, or via mobile app).

And then anyhow, report a bug on the bug tracker. However, it would be great to have some details so people can try to reproduce the issue (which versions you used, what change since you used it for the last time, log entries, …).

1 Like

So some of the files/directories look normal within your encrypted folder (HOME)? Can you see any patterns to the ones that look normal? (e.g. recently modified, not modified in a long time, etc.)?

Thanks a lot for your response!

Removing all local files and updating to 3.12.2 solved the problem.

In case I encounter issues in the future, where can I find the log files?


I don’t see any pattern.