Some configuration that I can't fix yet!

Hi, I’m new using Nextcloud in my work.

I have some problems with it. In the Main View on Admin panel, I can see some warnings.

I cound´t fix the “.htaccess doest work” and “Http Stritc transport security is not correcntly configured at least 15552000 seconds”.

I see a lot of information on the internet and on this page but for some reasons the config files doest work for me.

Let me show you what I did in both cases. (I hope you can help me a lot guys:smile:)

I use the guide: https://docs.nextcloud.com/server/17/admin_manual/installation/harden_server.html#enable-http-strict-transport-security

The only file I could find on my machine was:

find / -name nextcloud.conf
/etc/httpd/conf.d/nextcloud.conf
/etc/httpd/sites-enabled/nextcloud.conf
/etc/httpd/sites-available/nextcloud.conf

For the /etc/httpd/sites-enabled/nextcloud.conf I added the lines:

Also, I added the AllowOverride All for the .htaccess error, but I get always the same warnings (I restarted the httpd service and I restarted the enterly machine also).

I have no enough experience on Linux and webservers :frowning:

Maybe I forgot something in the way

Thanks in advance for your time.

Sorry, I forgot something.

My machine specs:

CentOS 8
httpd service
nextcloud ver 19.0.0
MariaDB as database

‘a2enmod headers && systemctl reload apache2’
and Weclome @Badrider306 to the Nextcloud community

Thank you so much.

Sorry, I had to pay attention to another things and I forgot this.

What you mean with the ‘a2enmod headers && systemctl reload apache2’?. Can you explain it a little bit more?.

I am not familiar with webservers. Thank you!

1 Like

The a2enmod headers enabled the mod headers and systemctl reload apache2 reload apache2

Also this might help:


have it updated for you server version

Yes, I did that, I added the LINES in my config file for httpd (I don’t have apache). Like this:

<IfModule mod_headers.c>
  Header always set Strict-Transport-Security "max-age=15552000; includeSubDomains"
</IfModule>

I putted in the first post the image with that.

I don’t know how to enable the a2enmod, can you explain it a little more?. Thank you!

Oh that is for apache

I thought that httpd was apache2

input: httpd -t -D DUMP_MODULES | grep header
Output: headers_module (shared)

I saw on internet, if I have this like that, my ae2mod is enabled, but I dont sure abaut that

Sorry, is not enable. Is ae2mod for apache right?

a2enmod is the command for apache2,

so is systemctl reload apache2,
try apache2 -v what happens?

apache2 -v
bash: apache2: command not found

Ok, that is what I thought would happen. I am sorry I could not be much help, I don’t know much about centOS or httpd. Sorry for wasting your time.

1 Like

Don’t worry. I apreciatte you tried to help me. Thank you.

1 Like