[solved] V16 desktop sync does not work


Running NC 16.02 out of the official container supplied via docker hub and facing an issue when 2fa is turned on when trying to set up a sync clients on both Linux and Mac.

The issue is that I try to login using ‘apptoken’ and after clicking grant in the process get a blank screen that never loads. Upon right clicking and ‘viewing page source’ I get taken to https://nc.url/login/flow/apptoken which results in a 405 error.

I can’t find much on this via Google etc. Where do I start? I don’t see anything in the console useful except this:

2019-07-08T16:27:16.251237009Z - - [08/Jul/2019:16:27:16 +0000] "GET /login/flow/apptoken HTTP/1.0" 405 882 "-" "Mozilla/5.0 (Macintosh) mirall/2.5.2git (build 20190319) (Nextcloud)"
2019-07-08T16:27:16.333443769Z - - [08/Jul/2019:16:27:16 +0000] "GET /favicon.ico HTTP/1.0" 302 906 "-" "Mozilla/5.0 (Macintosh) mirall/2.5.2git (build 20190319) (Nextcloud)"
2019-07-08T16:27:16.409657089Z - - [08/Jul/2019:16:27:16 +0000] "GET /login HTTP/1.0" 200 2861 "-" "Mozilla/5.0 (Macintosh) mirall/2.5.2git (build 20190319) (Nextcloud)"

I should add the reason I tried apptoken was because the standard 2fa login process just spins me round and round (only when trying to add the desktop client, otherwise 2fa login works great). I click grant access and then it spits me back to login and so on.

I did find this github issue too which I thought might be related.

Further investigation suggests that I might not be alone with the desktop client not working properly on v16 + mysql backend.

Any hints or tips would be welcomed.

This solution worked for me.