SOLVED - Upgraded NC & PHP and now dealing with a HTTP ERROR 500 - Please help :-)

Hi All,

I am running NC on Ubuntu 16.04.6 LTS with apache2 hosted on Digital Ocean.

Yesterday I tried updating from 14 something to the latest NC 15 from the settings page in NC and the update stalled on the 5th step, sorry I’m past that now and do not have the exact language available to post.

So I did a manual upgrade to 15.0.5 and it was working fine.

Today I updated PHP from 7.0 to PHP 7.2 and that broke my connection to NC. Running apt update & upgrade after the PHP update brought my PHP version to 7.3.3.

The server I updated also hosts several other URL’s and those ARE working…it is only my NextCloud install that is returning the 500 error.

Any advice on how and where to start to address this?

Cheers and thanks in advance for any replies.


As usual make sure that your web server is running and have look on the Nextcloud log file. There you should find information about the root cause of the problem. Very often the required PHP module for the database is not loaded, which is a must have requirement for Nextcloud.

Thanks for the reply.

The web server is running, “service apache2 status” returns: Active: active (running) since… and as my op stated the server is serving up a few other URL’s I host.

The last line in my log file reads (I’ve redacted the URL and user with place holders):

{“reqId”:“qMHCDVcD6tn8u4BU5lYA”,“level”:3,“time”:“2019-03-21T00:59:30+00:00”,“remoteAddr”:“REDACTED IP ADDRESS”,“user”:“REDACTED USER”,“app”:“core”,“method”:“GET”,“url”:"/index.php/core/preview.png?file=Things%20to%20Sell/Rest/2019-01-11%2008.50.31.jpg&x=281&y=609&a=$

I am a novice at best and do not understand the issue this log post is referencing, any help understanding it would be appreciated. Also, this comes from the nextcloud.log file in my data directory. Is there any other logs I should be reviewing?

Could you tell me how I can check on this?

More info for those who might be inclined to help…and I NEED help :slight_smile:
Since my original post, I have updated to Ubuntu 18.04.2 LTS and I have updated to PHP 7.3

Running php -v returns

PHP (cli) (built: Mar 7 2019 20:31:49) ( NTS ) Copyright (c) 1997-2018 The PHP Group Zend Engine v3.3.3, Copyright (c) 1998-2018 Zend Technologies with Zend OPcache, Copyright (c) 1999-2018, by Zend Technologies

I also have installed the following PHP modules:

php-pear php7.3-curl php7.3-dev php7.3-gd php7.3-mbstring php7.3-zip php7.3-mysql php7.3-xml

Are there any other’s I might be missing?

Running apache2 -v returns:

Server version: Apache/2.4.29 (Ubuntu)
Server built:   2018-10-10T18:59:25

I’ve been reading posts looking for similar issues, it seems I am not alone in this trouble but I have yet to find a solution. One post theorized it had to do with a conflict between PHP and MySql. On the off chance, I ran a check on my MySQL install and

dpkg --get-selections | grep mysql

returned this:

mysql-client-5.7				install
mysql-client-core-5.7				install
mysql-common					install
mysql-server					install
mysql-server-5.7				install
mysql-server-core-5.7				install
php-mysql					install
php7.0-mysql					deinstall
php7.3-mysql					install

Is the line php7.0-mysql deinstall problematic?

If I can’t solve this, I’m game for scrapping my current NC install and starting over with a new install. If I do, do I need to uninstall MySQL and reinstall that as well?

Any and all help will be greatly appreciated.

You cannot use the php command line program (cli) to check if all php modules for the web access are loaded. The only way to do this is by creating e.g. an info.php file which contains the following code <?php phpinfo() ?>. This need to be saved in your web server root. Once you’ve done this you should check which modules are loaded by accessing the url http://<your-server-name-or-ip>/info.php . Don’t forget to remove that script at the end to keep your server secure :wink:

hey, ubuntu is not windoze - continually uninstalling and reinstalling will not solve errors.
go to the admin handbook and double-check that all the required modules are installed and loaded. if you reinstalled/updated stuff recently you might need to do a dpkg --configure -a
restart apache.
run the occ-command with check; on debian it works like this (adjust your paths and user):
sudo -u www-data /usr/bin/php [NC-DIR]/occ check
open the login-page check the apache log(s). apache is usually pretty clear about 500-errors.

@j-ed & @pete.dawgg thanks for the help. @j-ed your info.php suggestion did the trick. Appears somewhere in the upgrading of PHP from 7.0 to 7.2 to 7.3 I goofed up. I had deactiveted 7.0 and activated 7.2 and though php -v returned PHP the header of the info.php page indicated it was utilizing 7.2. so I a2dismod 7.2 and a2enmod 7.3 with an A2 restart and presto chango!

Thanks for all your help and yes I deleted the info.php file :-):wink:

1 Like