[SOLVED] Php module GD not installed error (yes, installed)

[Later update: Today I ran openSUSE Tumbleweed updates and logged into my Nextcloud server. Instead of the php module GD error, I got a screen for updating to 9.0.53 (I think that is the correct number), the updates ran and then I could log in normally to my nextcloud server. 'Twas a lot of troubleshooting just to get back to “normal”.]

I wonder if anyone can tell me where the code is that checks for module GD, as I would like to comment it out and see if Nextcloud will run.

This is not a new install. I upgraded to Nextcloud from Owncloud following instructions posted by Jos Poortvliet. Nextcloud ran perfectly fine for quite awhile on my openSUSE 13.2 server.

However, I just upgraded my server to openSUSE Tumbleweed, with the result that Nextcloud will not run. Error message is “Php module GD not installed.” I believe it is installed.

I have read a number of Owncloud reports of this issue on multiple websites and I have followed the various solutions to check whether module GD is in fact installed. As far as I can tell, it is in working order. It is reported with phpinfo. gd.ini exists and references gd.so properly. GD.so exists.

I rely heavily on nextcloud, so would like to get it running. In the early days of owncloud I occasionally had to reinstall it, but this is the first time I have been unable to actually get it to run. Maybe there are some legacy issues in my server, since I did an upgrade to Tumbleweed rather than a clean install.

Please post a link to your complete phpinfo output. You can do this by uploading a file named phpinfo.php with the content:`


The whole output is required, can you upload the HTML page to https://gist.github.com/ and then use https://rawgit.com/ to make it accessible in a sanely displayed way?

Here is a link to a static page of the phpinfo() I saved from my server.


Further updates: I found that openSUSE build service now has some one-click installs (as opposed to installing from the zip file), so I tried installing that. No change to the problem, but it must be some legacy issue as the result of updating openSUSE from 13.2 to Tumbleweed, I guess.

I then installed a Nextcloud server on another computer I have that is running a clean install of openSUSE Tumbleweed. This worked, although I had some difficulties. FYI, in case it helps someone else reading these posts, everything installed (Nextcloud/LAMP server, etc.) with php7 – but then php did not work. In some instances I was getting a “forbidden” response, but with respect to the Nextcloud index.php, Firefox was offering to download it or open it in LibreOffice.

I then “rolled back” to php5 – everything worked and the initial Nextcloud page for completing the setup came up. But, I wanted to know if it would run with php7, so I re-upgraded to php7 via YAST and the server was now running correctly. I created the necessary user and database via phpMyAdmin and ran the Nextcloud setup page.

This raises a couple of questions – is there an easy way to get my existing data into the system, such as copy it into the data location and run the occ script to find files?

The second question is whether it is possible to synchronize two servers and how difficult that task might be. It would be nice to have one running if the other goes down.