[SOLVED] Passwords app - Delete Everything not working

Hello friends,
I’m trying to delete all the data I entered in the Passwords Nextcloud app.
To do that I go to Passwords->More->Settings->Danger Zone->Delete Everything.
I then enter my Nextcloud user password and press “OK”.
Unfortunately, for some reason I’m getting an error alert saying “Invalid Password”, even though I’m defenitly using the right user password.

Is this a bug or am I doing something wrong?
Is there another way to delete all the Passwords app data?
Hope someone can help :pray:

If your Nextcloud uses an external user backen (SAML, social login etc.) this prompt might not work.
Updating to the latest version (2021.5.0) should fix the issue.

Alternatively you can ask an administrator to use the occ command passwords:user:delete <user id> to delete the data. Make sure to use the internal NC user id for your account or nothing will be deleted.

1 Like

Hi @mdw, thank you for your reply.
My user is the admin user of my Nextcloud system.
I’m not sure I have any external user backend (SAML, social login, etc) enabled.
I mostly just ran the NextcloudPi curl installer and so far added these apps:
Passwords, Music, Talk, TOTP, End-to-End Encryption.

Do you mean I need to update the Passwords app to version (2021.5.0)?
My Nextcloud shows my Passwords app is on version (2020.12.3).
I tried to run nc-update-nc-apps in the NextcloudPi panel, but it didnt update the Passwords app to the version you mentioned.

I’m sorry for being a noob, but how do I run such occ command?
I’m not a developer, so, unfortunately, I don’t know how to do it.
I could use some guidance :pray:

You can either run occ command in a terminal in the installation directory of your Nextcloud by typing php ./occ <command> or using the occweb app.

1 Like

Yes, but since you’re using NextcloudPi, 2020.12.3 is the latest currently available there.

1 Like

Thank you.
Is this the right Nextcloud directory location /var/www/nextcloud ?
I’m getting an error message when I try to open it in terminal.

pi@raspberrypi:~ $ cd /var/www/nextcloud
bash: cd: /var/www/nextcloud: Permission denied

I think you need to change the user. sudu -u www-data bash and then run the commands.

Also if the command succeeds, but the data is not deleted, you used the wrong user id. This is a known issue in 2020.4 and prior

1 Like