[SOLVED] Onlyoffice no more working with nextcloud

After upgrading apps (and OS) Onlyoffice connexion from nextcloud does not work anymore.

I seem’s a “js” directory is missing in the apps/onlyoffice directory…
I get the folowing message in nextcloud.log :

“GET”,“url”:“/apps/files/files”,“message”:“Could not find resource onlyoffice/js/onlyoffice-desktop.js to load”
“GET”,“url”:“/apps/files/files”,“message”:“Could not find resource onlyoffice/js/onlyoffice-main.js to load”
“GET”,“url”:“/apps/files/files”,“message”:“Could not find resource onlyoffice/js/onlyoffice-template.js to load”
“GET”,“url”:“/apps/files/files”,“message”:“Could not find resource onlyoffice/js/onlyoffice-viewer.js to load”
“GET”,“url”:“/apps/files/files”,“message”:“Could not find resource onlyoffice/js/onlyoffice-listener.js to load”

And indeed in my nextcloud/apps/onlyoffice I do not have a js directory…

Any idee why? and how to solved?

Ps : My onlyoffice is running on the same server ans seem’s to works.
connexion from nextcloud to onlyoffice seem’s to work :

sudo -u www-data php occ onlyoffice:documentserver --check
Document server https://onlyoffice.mydomaine.net/ version is successfully connected

Same issue here, I just updated the Onlyoffice app on my Nextcloud, and I get the same error messages.
Please help to solve this!

The js folder ist missing in 9.1.
Download 9.0 here. Unzip an copy the js folder in the app/onlyoffice folder.
Guess there will be an update with the missing files in onlyoffice 9.2

1 Like

You saved me… Thank you!

I just updated to 9.1.2, and this problem is fixed.

1 Like

Thanks for the link Nelli I was trying to get a backup of my nextcloud.
Subject SOLVED with the 9.1.2 Update

Problem not solved for me 9.1.2

Result: Document server https://docs.xxx.xx/ version is successfully connected

But when I connect to my NC administration panel, it said that no OO server present…

All parameters are OK, Token, URL, RP, config file…

Solved deactivated, uninstalled, manually download and added to /var/******/app from the git

1 Like


Must ask: I have the exact same problem → „ONLYOFFICE ist zurzeit nicht erreichbar. Bitte wende Dich an Deinen Administrator“ (ONLYOFFICE is currently not available. Please contact your administrator)

Im Log: → [jsresourceloader] Fehler: Could not find resource onlyoffice/js/desktop.js to load

GET /apps/dashboard/

von von nc_admin um 21.04.2024, 17:01:59

xxxx@pNexCloud:/var/www/nextcloud# sudo -u www-data php occ onlyoffice:documentserver --check

Document server https://oo.xxxxxxxx.de/ version is successfully connected

Also made flying: → deactivated, uninstalled, manually download and added to /var/******/app from the git =>


Reboot from Nextcloud and Rebbot from Documentserver

Nextcloud and OO-Documentserver runing on „Proxmox“ VM.

1 Like

Thanks for posting!

Thanks for the additional detail - exactly what I needed!

Same Problem here, but this solution did not work for me.
The error stays but onlyoffice is working fine.