[Solved] No more able to connect via Caldav

EDIT : See my last message about the bruteforce parameter.


I’ve updated from 11.0.1 to 11.0.2 and I can’t connect anymore to CalDav with OSX/iOS.
It says that user or password is incorrect, but it has not changed.
(and the login to the web interface in now very long : > 10s)

I’ve tried to connect using the advanced way, specifying user, password, url, path, port (443).
My certificate is generated via letsencrypt, and here is the vhost :

    <VirtualHost *:443>

            ServerAdmin     n@mydomain.org

            ServerName      co.mydomain.org

            DocumentRoot "/home/nextcloud/www/co.mydomain.org"

            <Directory /home/nextcloud/www/co.mydomain.org>
                    Options -Indexes +FollowSymLinks +MultiViews
                    Require all granted
                    AllowOverride All

            <IfModule mod_dav.c>
                    Dav off

            Redirect 301 /.well-known/carddav /remote.php/dav
            Redirect 301 /.well-known/caldav /remote.php/dav

            SetEnv HOME /home/nextcloud/www/co.mydomain.org
            SetEnv HTTP_HOME /home/nextcloud/www/co.mydomain.org

            SSLCertificateFile /etc/letsencrypt/live/co.mydomain.org/fullchain.pem
            SSLCertificateKeyFile /etc/letsencrypt/live/co.mydomain.org/privkey.pem
            Include /etc/letsencrypt/options-ssl-apache.conf

            <IfModule mod_headers.c>
                    Header always set Strict-Transport-Security "max-age=15552000; includeSubDomains"

            ErrorLog /var/log/apache2/_sites/co.mydomain.org.error.log
            LogLevel crit
            CustomLog /var/log/apache2/_sites/co.mydomain.org.access.log combined


Is there a way to show some log when the OSX calendar app is trying to connect to see what happened exactly ?

Thx !

Nextcloud version (11.0.2):
Operating system and version (Debian 8.7.1):
Apache or nginx version (Apache 2.4.10):
PHP version (5.6.30-0+deb8u1):
Is this the first time you’ve seen this error and can you replicate it?:
I can replicate it every single time.

The issue you are facing:
Cannot connect via Caldav.

The output of your Nextcloud log in Admin > Logging:
Doesn’t show any error.

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
‘instanceid’ => ‘XXX’,
‘passwordsalt’ => ‘XXX’,
‘secret’ => ‘XXX’,
‘trusted_domains’ =>
array (
0 => ‘co.mydomain.org’,
‘datadirectory’ => ‘/home/nextcloud/www/co.mydomain.org/data’,
‘overwrite.cli.url’ => ‘https://co.mydomain.org’,
‘dbtype’ => ‘mysql’,
‘version’ => ‘’,
‘dbname’ => ‘nextcloud’,
‘dbhost’ => ‘localhost’,
‘dbport’ => ‘’,
‘dbtableprefix’ => ‘oc_’,
‘dbuser’ => ‘nextcloud’,
‘dbpassword’ => ‘XXX’,
‘logtimezone’ => ‘UTC’,
‘installed’ => true,
‘updater.secret’ => ‘XXX’,
‘maintenance’ => false,
‘theme’ => ‘’,
‘loglevel’ => 1,

The calendar app console on OSX says that it timed out the authentification…:

[com.apple.calendar.accounts.authentication] [We timed out waiting for CalendarAgent to authenticate testnico (7DCEE6DE-E8C2-4558-953D-06DC872F27F9).]

[com.apple.calendar.accounts.authentication] [We finished authenticating testnico (7DCEE6DE-E8C2-4558-953D-06DC872F27F9) with error Error Domain=com.apple.accounts Code=1 “(null)”.]

I’ve solved this by changing my own IP… That’s a very weird problem.
This ticket can be closed, it’s not nextcloud relative…

Have a look in the bruteforce table in your database…

1 Like

Thx Soko, that did the trick !
Didn’t know about the bruteforce parameter… I’ve cleaned the table and everything goes fine now !

1 Like