[Solved] Nextcloud wrong LDAP DN


I installed Nextcloud nextcloud-9.0.53 on Centos 7.
Anything works well but if I tried to login a ldap user I get in the UI “Wrong password. Reset it”. But the password is valid. I use FreeIPA as LDAP server.
And in the log file I see following message:

{"reqId":"WJC4DhDrvHpjda4LQ54pDAAAAAU","remoteAddr":"","app":"user_ldap","message":"Could not autodetect the UUID attribute","level":3,"time":"2017-01-31T16:15:10+00:00","method":"POST","url":"\/nextcloud\/index.php","user":"--"}
{"reqId":"WJC4DhDrvHpjda4LQ54pDAAAAAU","remoteAddr":"","app":"user_ldap","message":"LDAP Login: Could not get user object for DN uid=test.user,cn=users,cn=compat,dc=example,dc=lan. Maybe the LDAP entry has no set display name attribute?","level":2,"time":"2017-01-31T16:15:10+00:00","method":"POST","url":"\/nextcloud\/index.php","user":"--"}
{"reqId":"WJC4DhDrvHpjda4LQ54pDAAAAAU","remoteAddr":"","app":"core","message":"Login failed: 'test.user' (Remote IP: '')","level":2,"time":"2017-01-31T16:15:10+00:00","method":"POST","url":"\/nextcloud\/index.php","user":"--"}

What I see is that the ldap dn is wrong uid=test.user,cn=users,cn=compat,dc=example,dc=lan it musst be uid=test.user,cn=users,cn=accounts,dc=example,dc=lan

I have no group compat given im my setting. My ldap settings are as follow:

Ldap host: user.example.lan 389
DN of the client: uid=admin,cn=users,cn=accounts,dc=example,dc=lan
Password: ********
Base DN: dc=example,dc=lan

Thats all.
If press the button “Verify Settings and count users” I get as result two. And also the users are listed in users.

Why is the DN false? Why is there cn=compat in the search string?

This are programs which I have installed before nextcloud.

yum install -y httpd php php-mysql sqlite php-dom php-mbstring php-gd php-pdo php-json php-xml php-zip php-gd curl php-curl php-mcrypt php-pear wget unzip php-ldap bzip2

I tried the DN uid=test.user,cn=users,cn=compat,dc=example,dc=lan in a ldap tool and it works.
All users are under a cn compat. I know I got it working some days ago.

I fixed it.

In the LDAP configuration section under Advanced -> Directory settings.

I have change the Base User Tree: from dc=example,dc=lan to cn=users,cn=accounts,dc=example,dc=lan
and Base Group Tree from dc=example,dc=lan to cn=groups,cn=accounts,dc=meerkatsoftware,dc=lan.

Nextcloud seems to be very cool. And works great with android