[SOLVED] Nextcloud Box - crashes offen


I am doing a desperate call for help. I have a Nextcloud Box from 2 years ago. I have been using it for small uploads. I decided to start using to move away from other providers.

Now that I have installed the iOS client app, the server start crashing. Similar to the issue here: RaspberryPi 3 abnormal crashes . Unfortunately, I have not been able to solve the issue with the solutions posted.

The issue you are facing is simple, normal use of 1 user and NC crashes, including the complete server (SSH).

I have monitored the performance and resources. And before I load a file or a picture or any use via iOS client app, the Memory usages goes from 200 MB till 862 MB, and it crashes. Raspberry PI 3 has only 1 GB RAM and seems to be overloaded by simple basic use. I tried to enable SWAP to see if it helps with 2 GB. But still the same. This assumption can be wrong, maybe the issue is somewhere else… any help in diagnosis would be great.

At this point it kind renders unusable the box.

Does anybody has any idea or tips so the NC doesn’t crash?

Is any body using actively the Nextcloud Box that is not affected by this?


Nextcloud version _:13.0.7
Operating system and version __:Ubuntu core
PHP version __:7.1.22

If you are using a single power source, try using 2, one for rpi and 1 for the drive.
My PiBox was gathering dust, for some time, from pure frustration, untill I decided to give it a try with 2 hi quality power sources.
You can also try to free some memory towards cpu by reducing gpu value to 64 from raspi-config menu>advanced options>memory split.
The manual reads you can choose value as low as 16 and 32, but mine wont keep any value below 64.After setting this and rebooting my pi has 937Mb of available RAM

Btw I use NextCloudPi (Debian/Raspbian9) for installation and running NC14.0.3 presently, i can upload big VM.ova files or copy a 5.5Gb folder, no problem,  it takes time but it gets there.

Thanks for the reply.
You are absolutely right. I connected the Nextcloud Box to 2 power sources of 2.1A each and works. And solved as well the memory issue. All this years installing and re-installing the OS. It was a problem of the power.

1 Like

I was experiencing the same problem suddenly due to unknown reasons. Reducing GPU shared RAM and two separate power sources did not help me, but enabling swap on Ubuntu core:

  1. edit /etc/default/swapfile and set SIZE to a non-zero value.
  2. sudo systemctl enable --now swapfile.service
1 Like