[Solved] Nextcloud 21 very slow and connection impossible since upgrade


I have upgrade my Nextcloud 18 to latest 21 version but I can’t use it because it’s too slow (60sec to print login page) and I can connect myself : no error, just login page.
The different upgrades (18->19->20-21) were done by CLI like a charm, with no error.
But now I can’t log in and I don’t have any significant error log.

I have tried to install a fresh new NextCloud instance and it’s work fine.

What could be the cause of this issue ?

On the admin page, you sometimes see some hints when some further manual changes have to be executed on the database. It can help to increase the log level, or besides of that you can try and see which resources take a long time to load, e.g. if there is a long database query, etc.
It could also be some app that has a problem …

Same here, but from 18 to 19…Check postgres (or database) load. Load is exploding and troubleshoot queries being made in order to check queries like:

“LOG: execute : SELECT “filecache”.“fileid”, “storage”, “path”, “path_hash”, “filecache”.“parent”, “name”, “mimetype”, “mimepart”, “size”, “mtime”, “storage_mtime”, “encrypted”, “etag”, “permissions”, “checksum”, “metadata_etag”, “creation_time”, “upload_time” FROM “oc_filecache” “filecache” LEFT JOIN “oc_filecache_extended” “fe” ON “filecache”.“fileid” = “fe”.“fileid” WHERE “filecache”.“parent” = $1 ORDER BY “name” ASC
DETAIL: parameters: $1 = ‘511142’”

Constantly being made and oc_filecache incrising (~171Mb).
What causes this I don’t know, but everytime I hit a page on nextcloud 19, load on postgres goes sky high an the response is very very slow (but no errors).

Hope that you somehow can check if it is something similar…

Thanks @tflidd
I will try to disable application just in case.

@Nuno_Goncalves : I also have a big oc_filecache table and you maybe have found something.
But I don’t know why this table is growing so fast and how to solve the issue…

I have solved my issue by disabling applications on CLi :

comments 1.10.0 disabled
contactsinteraction 1.1.0 disabled
deck 1.2.6 disabled
federatedfilesharing can’t be disabled.
federation 1.10.1 disabled
files_videoplayer 1.9.0 disabled
files_versions 1.13.0 disabled
files_mindmap 0.0.24 disabled
firstrunwizard 2.9.0 disabled
logreader 2.5.0 disabled
notes 4.0.4 disabled
oauth2 can’t be disabled.
onlyoffice 6.3.0 disabled
password_policy 1.10.1 disabled
recommendations 0.8.0 disabled
richdocuments 3.7.17 disabled
sharebymail 1.10.0 disabled
support 1.3.0 disabled
survey_client 1.8.0 disabled
systemtags 1.10.0 disabled
twofactor_backupcodes can’t be disabled.
unsplash 1.2.2 disabled

I don’t know for now precisely which one caused issue, but maybe onlyoffice or unsplash…

My nextcloud is very very fast now :slight_smile:

Yep, I am following that path :slight_smile: have a snapshot of the Virtual Machine which is running nextcloud 18, now I am disabling and removing unused apps and then will make the upgrade to latest 18 and then 19.

Also don’t know why is oc_filecache growing and growing days after the upgrade and causing the whole thing to be super slow (with postgress above 80%/90% Load) specially if I click on a file on the nextcloud web browser :stuck_out_tongue:

Let’s see what happens with this approach…But it might be an app somehow that could cause this behaviour…