Solved: Nextant solr Expected directory /opt/solr-7.0.1-src not found

Hi all,

I’m currently trying to install nextant with solr using the guide found here: However when running the script like this: ./solr-7.0.1/solr/bin/ solr-7.0.1-src.tgz I get the following error:

ERROR: Specified Solr installation archive solr-7.0.1-src.tgz not found!

This is all I did before attempting to run the script:

  • check what version of java is installed
    root@myserver:/home/beheerder# java -version
    bash: java: command not found

  • install java
    sudo apt-get install default-jre

  • check java version again
    root@myserver:/home/beheerder# java -version
    openjdk version "1.8.0_131"
    OpenJDK Runtime Environment (build 1.8.0_131-8u131-b11-2ubuntu1.16.04.3-b11)
    OpenJDK 64-Bit Server VM (build 25.131-b11, mixed mode)

  • create new directory for solr
    mkdir ~/solr_install/

  • change directory to the dir I just created
    cd ~/solr_install/

  • get the latest version of solr that I could find
    root@myserver/solr_install# wget

  • extract the downloaded package
    root@myserver/solr_install# tar -zxvf solr-7.0.1-src.tgz

  • chmod +x so that the script is executable
    root@myserver:~/solr_install/solr-7.0.1/solr/bin# chmod +x

  • run the script
    root@myserver:~/solr_install# ./solr-7.0.1/solr/bin/ solr-7.0.1-src.tgz
    We recommend installing the ‘lsof’ command for more stable start/stop of Solr
    id: ‘solr’: no such user
    Creating new user: solr
    Adding system user solr' (UID 111) ... Adding new groupsolr’ (GID 118) …
    Adding new user solr' (UID 111) with groupsolr’ …
    Creating home directory `/var/solr’ …
    Extracting solr-7.0.1-src.tgz to /opt
    ERROR: Expected directory /opt/solr-7.0.1-src not found after extracting solr-7.0.1-src.tgz … script fails.

Is there anything that I missed, forgot or done wrong?
Many thanks!

System info:
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 16.04.3 LTS
Release: 16.04
Codename: xenial

it seems that Nextant is not working with solr7, you should try with the lastest version of Solr 6.x

I see,

I’m going to try that :slight_smile:
I’ll let you and the others reading this post know what the results are.

Just tried installing solr-6.4.1 and everything is now fully functional!
I’ll try upgrading to the latest version of 6.x.x later.

Many thanks!