[SOLVED] Nc-rsync to OpenSSH server

Hi, I am new here and installed Nextcloud by using NextcloudPi to RPI4 B. Everything else is ok but nc-rsync is not succeeding to my OpenSSH server. I have configured keys and according to these instructions, rsync via ssh should be possible.
Manually rsync works OK according these instructions.
But when I am trying via nc webview, I get these error lines:


[ nc-rsync ] (Sun Feb 7 11:17:49 GMT 2021)
Maintenance mode enabled
Nextcloud is in maintenance mode - no apps have been loaded

Host key verification failed.
rsync: connection unexpectedly closed (0 bytes received so far) [sender]
rsync error: unexplained error (code 255) at io.c(235) [sender=3.1.3]
Maintenance mode disabled

Ah, my bad: I forgot to change to root account in Rpi4:

  • change to the root account (sudo -s)
  • go to the home directory of the root (cd ~)
  • follow these steps to create the auto-login for the root user: SSH login without password (a: root user, A: the IP of the ncp, b: user at the backup-server, B: IP of the backup server)
  • make sure that ssh-access works for the root user to the backup-server

Case Solved.

1 Like