[solved] Md5sum and sha256sum both fail on latest download

There seems to be a problem with the latest release. I am trying to install it on a new server instance, and when comparing the md5 on the downloaded zip file to the md5sum provided, I get the following:

md5sum: WARNING: 1 computed checksum did NOT match
mikeg@mg-kubuntu:~/Downloads/nextcloud$ cat nextcloud-11.0.1.zip.md5 
48b9b9f3a290c07bfa6f58e5c798d913  nextcloud-11.0.1.zip
mikeg@mg-kubuntu:~/Downloads/nextcloud$ md5sum nextcloud-11.0.1.zip
96bd52b37dbd079a59c20ac5c63a7ee6  nextcloud-11.0.1.zip```

I do not want to proceed with installation if the install files cannot be verified. Any suggestions?

Download it again

Thanks Sanook,
I agree, and did download it again, 3 times on 2 different machines, with the same issue. Downloaded via wget and web browser, no difference. My guess is that something has changed in the package offered for download, and that the recorded md5sum hasn’t been updated. I’m hoping one of the devs sees this post and checks the stored package against the stored md5sum. It may just be a mismatch, perhaps I will just wait and try the download again later.

@jospoortvliet @LukasReschke

$ md5sum nextcloud-11.0.1.zip brings up 48b9b9f3a290c07bfa6f58e5c798d913
https://download.nextcloud.com/server/releases/nextcloud-11.0.1.zip.md5 shows 48b9b9f3a290c07bfa6f58e5c798d913

With md5sum I get exactly the checksum it should be.

$ sha256sum nextcloud-11.0.1.zip brings up e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855
https://download.nextcloud.com/server/releases/nextcloud-11.0.1.zip.sha256 shows 6194832867811c8a90e77e59338161859776a6b1937c9b7ed67b64bec66df4b3

$ sha512sum nextcloud-11.0.1.zip brings up cf83e1357eefb8bdf1542850d66d8007d620e4050b5715dc83f4a921d36ce9ce47d0d13c5d85f2b0ff8318d2877eec2f63b931bd47417a81a538327af927da3e
https://download.nextcloud.com/server/releases/nextcloud-11.0.1.zip.sha512 shows 12f076912e9d5898c930c596eab2df62c5202b665b3166dad4b8ad7928ed8a9282b0f2fd1cc8569261179ed88afe576d8fc4823c7d2ed7a5fd4cd5bd26419922

The checksums for sha256 and sha512 are different !

Maybe solved:
I went here: https://nextcloud.com/changelog/#latest11 to download the tar.bz2 version and the sha256 and sha512 files, and now I get matching checksums.

00162bf454914a2acbe6a9ac47c9db9f411b99064f0736b43e73cabbd87f4629  nextcloud-11.0.1.tar.bz2
mikeg@mg-kubuntu:~/Downloads/nextcloud$ cat nextcloud-11.0.1.tar.bz2.sha256 
00162bf454914a2acbe6a9ac47c9db9f411b99064f0736b43e73cabbd87f4629  nextcloud-11.0.1.tar.bz2
mikeg@mg-kubuntu:~/Downloads/nextcloud$ sha512sum nextcloud-11.0.1.tar.bz2
33bed146a984bd805a8648888db3fbe4f1bace3e59e64463ac66aedc6d73fa6ab231d83824eed8d551cd77dabfcdbc840c4fefd3d9a73cda82c7240705a43bdb  nextcloud-11.0.1.tar.bz2
mikeg@mg-kubuntu:~/Downloads/nextcloud$ cat nextcloud-11.0.1.tar.bz2.sha512 
33bed146a984bd805a8648888db3fbe4f1bace3e59e64463ac66aedc6d73fa6ab231d83824eed8d551cd77dabfcdbc840c4fefd3d9a73cda82c7240705a43bdb  nextcloud-11.0.1.tar.bz2```

Originally I had downloaded the files from here: https://download.nextcloud.com/server/releases/nextcloud-11.0.1.zip
There is a mismatch somewhere, but I feel safer with my latest download. Perhaps @jospoortvliet  or @LukasReschke  can investigate further about the mix-up.


I redownloaded nextcloud-11.0.1.zip from https://download.nextcloud.com/server/releases/nextcloud-11.0.1.zip.

MD5, SHA256 and SHA512 are now all matching with

Thanks to all. It does seem to be working properly now, not sure what happened with my initial tries at downloading.
Somewhere in the mix some checksum files seem to have gone wonky. Going to mark this one solved.