[SOLVED] Lost access to my nextcloudpi on new dodgy Router

Nextcloud version (eg, 20.0.5):
Operating system and version (eg, Ubuntu 20.04): Debian GNU/Linux 11. 5.10.103-v8+
Apache or nginx version (eg, Apache 2.4.25): don’t remember.
PHP version (eg, 7.4): 7.*
NexctloudPi v1.53.0

The issue you are facing:
My ISP suddenly changed my router and I don’t have access to the older one.
I had my nextcloudpi instance configured for Static IP and now the new router can’t assign an IP to my Rapsberry Pi. Also, I don’t have access to the new Router’s config.
Alternatively, I tried to login connecting directly to the device using an external screen and a keyboard. But I can’t, I think I disabled the ‘pi’ user, and the ‘ncp’ says “this account is currently not available”.

Any workaround to recover access? I bought a new decent router, hoping that it will recognize my Raspberry Pi and assign the static IP it was config.

Thank you for your help!

UPDATE: It ran plug-an-play in the new router, therefore the problem was the faulty ISP Router.

I just wanted to check with you guys: can the ‘pi’ user I setup for SSH access be used for local login using a keyboard and a screen?