[Solved] Internal Server Error opening Settings Page


i have a fresh installation of Nextcloud Everything works fine but i canĀ“t open the settings page. I enabled debug mode and get the following error:

Typ: Exception
Code: 0
Nachricht: Class 'OCA\Viewer\Event\LoadViewer' not found
Datei: /var/www/vhosts/diehartmanns.net/cloud.diehartmanns.net/lib/private/AppFramework/Http/Dispatcher.php
Zeile: 110


#0 /var/www/vhosts/diehartmanns.net/cloud.diehartmanns.net/lib/private/AppFramework/App.php(152): OC\AppFramework\Http\Dispatcher->dispatch()
#1 /var/www/vhosts/diehartmanns.net/cloud.diehartmanns.net/lib/private/Route/Router.php(308): OC\AppFramework\App::main()
#2 /var/www/vhosts/diehartmanns.net/cloud.diehartmanns.net/lib/base.php(1008): OC\Route\Router->match()
#3 /var/www/vhosts/diehartmanns.net/cloud.diehartmanns.net/index.php(37): OC::handleRequest()
#4 {main}

Any ideas?
Thank you!

EDIT: I tried the PLESK extension. Now it works.

could you please give a more detailed insight on what you did as an extra answer here? this would earn you a solution-credit :wink:

I didnĀ“t find a solution for this problem. I noticed that my PLESK installation got an extension for Nextcloud so i tried a new installation. This extension creates the databases, installed nextclout etc. Now i donĀ“t have the problems above anymore.