(SOLVED) Integrated OnlyOffice (NC18) throws 500 Internal Server Error

Edit:

Solved by reinstalling nextcloud, found no other way.

Dear Community,

I just wanted to install the Community Document Server app in NC 18 but when I hit save in the ONLYOFFICE settings, it gives me this error:

`

Fehler beim Anschließen (Server error: GET https://cloud.xxxxxxxx.de/apps/onlyoffice/empty?doc=eyJ0eXAiOiJKV1QiLCJhbGciOiJIUzI1NiJ9.eyJhY3Rpb24iOiJlbXB0eSJ9.UkWeJSv7a9mHBaRJfdCbJMDk8-_S_53XJmjnXtQCats resulted in a 500 Internal Server Error response: <head data-requesttok (truncated…) )

`

The nextcloud log file gives me this error:

> Request converted file on check error: Server error: GET https://cloud.xxxxx.de/apps/onlyoffice/empty?doc=eyJ0eXAiOiJKV1QiLCJhbGciOiJIUzI1NiJ9.eyJhY3Rpb24iOiJlbXB0eSJ9.UkWeJSv7a9mHBaRJfdCbJMDk8-_S_53XJmjnXtQCatsresulted in a500 Internal Server Error response: <!DOCTYPE html> <html class="ng-csp" data-placeholder-focus="false" lang="de" data-locale="de" > <head data-requesttok (truncated...)

and this error which may be related?

> InvalidArgumentException: Key may not be empty

I already tried completely removing the app and installing it again, no luck.
All settings look correct to me and the docker version still works (which I deactivated before trying the app), I checked the address (cloud.xxxx.de/apps/documentserver_community/) again and that looks fine.

Do you guys know what the problem might be?

Thank you!