[solved] Grant Access Loop on Linux Mint 20.1

Hi everyone, newbie here.

I’ve just upgraded my laptop to Linux Mint 20.1. Ever since the upgrade, I cannot connect my nextcloud sync client to my cloud any more, because I get stuck on the “grant access” page (Firefox). After I click the button, the loading icon starts spinning and nothing more happens.

I’ve tried re-installing the client several times, both from the “software manager” and the synaptic package manager - the two clients look slightly different, but they produce the same error.

Does anyone have any suggestions? Is there any more information I can provide? My next troubleshooting step would be switching my OS, which I don’t really want to :frowning:

Best and thanks in advance!

Did you try to remove all cookies on Firefox ?

A radical solution would be remove completly firefox & NC and reinstall them with the following commands :

 sudo apt autoremove --purge firefox 
 sudo apt autoremove --purge nextcloud-desktop
sudo apt install firefox nextcloud-desktop

Hi, bastien,
thanks for your suggestion. I tried it, unfortunately with no success. Thanks for your effort though, it is much appreciated :slight_smile:

Follwing advice from a friend, I also revoked all authorizations for clients and browsers from my nextcloud settings, then purged ff and nextcloud again and re-installed them again. I am still stuck with the same problem.

As of today, I am hardly able to perform any work on my laptop, so my next step would be to switch from Linux Mint to a different distribution :confused: Any troubleshooting advice before I take this step?

Do you have add on on firefox @The_T-Man ?
You can also try to remove firefox, and install temporarly chromium ?
Do you have any log ? Try to lunch NC client from a terminal to see logs

Hi there! I did have a version with add-ons. I consulted again with a friend of mine who hosts our server, he changed something in the configuration and it worked. For everyone else facing this kind of problem, I can unfortunately not provide the exact step that fixed it.
A previous attempt of removing all allowed devices from my accound and re-adding them had been unsuccessful. Thank you - again - very much for your kind help!