[SOLVED] Error when updating nextcloudpi

Hello!

I’m totally new to nextcloud and I ran into my first problem when I tried to update textcloudpi. I get the following output:

ncpadmin@nextcloudpi:~$ sudo ncp-update

Downloading updates

Performing updates

Update root login prevention method…

done.

Fixing trusted proxies list…

An unhandled exception has been thrown:

RedisException: read error on connection to /var/run/redis/redis.sock:0

in /var/www/nextcloud/lib/private/RedisFactory.php:123 Stack trace:

#0 /var/www/nextcloud/lib/private/RedisFactory.php(123): Redis->auth()

#1 /var/www/nextcloud/lib/private/RedisFactory.php(158):

OC\RedisFactory->create() #2

/var/www/nextcloud/lib/private/Memcache/Redis.php(70):

OC\RedisFactory->getInstance() #3

/var/www/nextcloud/lib/private/Memcache/Redis.php(76):

OC\Memcache\Redis->getCache() #4

/var/www/nextcloud/lib/private/App/InfoParser.php(58):

OC\Memcache\Redis->get() #5

/var/www/nextcloud/lib/private/App/AppManager.php(724):

OC\App\InfoParser->parse() #6

/var/www/nextcloud/lib/private/AppFramework/App.php(72):

OC\App\AppManager->getAppInfo() #7

/var/www/nextcloud/lib/private/legacy/OC_App.php(154):

OC\AppFramework\App::buildAppNamespace() #8

/var/www/nextcloud/lib/private/AppFramework/Bootstrap/Coordinator.php(119):

OC_App::registerAutoloading() #9

/var/www/nextcloud/lib/private/AppFramework/Bootstrap/Coordinator.php(90):

OC\AppFramework\Bootstrap\Coordinator->registerApps() #10

/var/www/nextcloud/lib/base.php(700):

OC\AppFramework\Bootstrap\Coordinator->runInitialRegistration() #11

/var/www/nextcloud/lib/base.php(1200): OC::init() #12

/var/www/nextcloud/console.php(48): require_once(‘…’) #13

/var/www/nextcloud/occ(11): require_once(‘…’) #14 {main}Error while

applying update 1.54.0. Exiting…

Any idea why I can’t update my nextcloudpi?

Thanks in advance!

seems like redis server is seriously broken. I cannot restart it or stop it. Therefore no peaceful reboot is possible. Any idea, what I can do?

So what i did: I force rebooted. Then redis worked again for some reason.

I tried to update again. But it got stuck and apt was unresponsive during the installation of zstd.

I force-rebooted, installed the package manually and ran sudo ncp-update again, and it worked.

SOLVED.