[Solved] Difficulties to get Collabora to work

Hi everyone,

Today I wanted to increase my freedom and install the collabora docker image on the server I use to run nextcloud.

Installing docker and starting the container seemed straightforward.
I access next from cloud.domain.tld and I created office.domain.tld for the proxy to collabora, so everythin like the installation tutorial.

in the ‘run’ command of docker I tried cloud.domain.tld and cloud\.domain\.tld with the same un-sucessful result … (encouraging!)

the issue seems to be between apache and the container when I access a file, I just get nothing, but here is what the apache log file looks like:

[proxy_http:error] [pid 10454] (103)Software caused connection abort: [client x.x.x.x:56247] AH01102: error reading status line from remote server
[proxy:error] [pid 10454] [client x.x.x.x:56247] AH00898: Error reading from remote server returned by /hosting/discovery
[proxy_http:error] [pid 10514] (103)Software caused connection abort: [client x.x.x.x:56250] AH01102: error reading status line from remote server
[proxy:error] [pid 10514] [client x.x.x.x:56250] AH00898: Error reading from remote server returned by /hosting/discovery

I basicaly copied the virtual host configuration from the tutorial …

Has anyone an idea of what to do to get apache and collabora to speak together ?

if you don’t get anything, please try that:

if that doesn’t help, please post:

error message
does https://collabora-domain/hosting/discovery show an xml File
docker ps
docker logs
result of docker info
anonymized docker start command
the anonymized content of their collabora-webinstance (f.e. /etc/apache/sites-enabled/collabora.domain.tld.conf)
which SSL-Certs are being used (self signed or from a recognized authority)
result of "uname -a"
the date of the download of the collabora-image
If it already worked or not and if possible with which image-date.

Thanks for your very quick reply!

In the mean time, I add forgoettent that iptables was locking a lot of stuff … after opening ports 9980, I now get to see collabora but now, I get an error in the docker container:

sd-00026-0029 16:41:14.322312 [ client_req_hdl ] WRN  WOPI host did not pass optional access_token_ttl| wsd/FileServer.cpp:255
wsd-00026-7234 16:41:34.936468 [ client_ws_0002 ] ERR  Error in client request handler: DNS error| wsd/LOOLWSD.cpp:1038

And to complete the reply:

nextcloud 11.0.1
latest plugin from apps store
the/hosting/discovery shows qn xml file
for the logs, see above
debian 8
code image downloaded this morning :slight_smile:
ssl from let’s encrypt generated yesterday

DNS Error seems a resolving issue in your setup, or a problem with you start command for the dockerimage

I just tried nslookup from inside the container but nslookup is not available …

I double checked my run command and use double backslash and the correct nextcloud domain name

I am using only one backslash.
mostly the containers are ubuntu or debian images so you should be able to install dnstools with apt.

Ok, so following your suggestion, I stopped and remove the container, created a new one with only one slash and tada!

Now it all works fine!

So as summary, I had to:

  1. open the proper port in iptables
  2. use only 1 backslash in the domain
1 Like

Hi, which port have you opened exactly? I´m struggeling with my iptables and I don´t get it working. Are you using nginx proxy?


i have the same Problem with my installation. i tried with one slash but the same Error 502

502	GET /hosting/discovery HTTP/1.1		
2017-06-14 07:42:00	Error		(103)Software caused connection abort: AH01102: error reading status line from remote server				Apache-Fehler
2017-06-14 07:42:00	Error		AH00898: Error reading from remote server returned by /hosting/discovery