[Solved] Cron.php silently fails from command line

Nextcloud version: 10.0.3
Operating system and version: Ubuntu 14.04
Apache or nginx version: Apache 2.4.7ubuntu4
PHP version: PHP 5.6.29-1+deb.sury.org~trusty+1
Is this the first time you’ve seen this error and can you replicate it?: no, yes

The issue you are facing:
cron.php doesn’t run from command line as user www-data it fails silently (not output on command line and nothing(?) in nextcloud.log)
root@xxx:/var/www/nextcloud# sudo -u www-data -s
bash: /root/.bashrc: Permission denied
www-data@xxx:/var/www/nextcloud$ php cron.php
www-data@xxx:/var/www/nextcloud$ echo $?

This is see since I first tried to use cron.php via crontab in version 10.0.2

The output of your Nextcloud log in Admin > Logging:
{“reqId”:“kS0rYopmmg/8GhD3/J5z”,“remoteAddr”:“”,“app”:“admin_audit”,“message”:“Login successful: “Henry78"”,“level”:1,“time”:“2017-01-17T20:34:30+00:00”,“method”:“REPORT”,“url”:”/remote.php/caldav/calendars/Henry78/garden/",“user”:“Henry78”,“version”:“”}
{“reqId”:“0cuuUof4iLGLkuIWcG2j”,“remoteAddr”:"",“app”:“cli”,“message”:“Memcache \OC\Memcache\APCu not available for local cache”,“level”:1,“time”:“2017-01-17T20:36:15+00:00”,“method”:"–",“url”:"–",“user”:"–",“version”:“”}
{“reqId”:“0cuuUof4iLGLkuIWcG2j”,“remoteAddr”:"",“app”:“cli”,“message”:“Memcache \OC\Memcache\APCu not available for distributed cache”,“level”:1,“time”:“2017-01-17T20:36:15+00:00”,“method”:"–",“url”:"–",“user”:"–",“version”:“”}
{“reqId”:“0cuuUof4iLGLkuIWcG2j”,“remoteAddr”:"",“app”:“PHP”,“message”:“Call to undefined function OC\AppFramework\simplexml_load_file() at /var/www/nextcloud/lib/private/AppFramework/App.php#60”,“level”:3,“time”:“2017-01-17T20:36:15+00:00”,“method”:"–",“url”:"–",“user”:"–",“version”:“”}

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php $CONFIG = array ( 'datadirectory' => '/var/lib/nextcloud/data/', 'dbtype' => 'mysql', 'version' => '', 'installedat' => '1336941442.5387', 'lastupdatedat' => '1340546480.2196', 'default_language' => 'de', 'dbname' => 'owncloud', 'dbhost' => 'localhost', 'dbtableprefix' => 'oc_', 'dbuser' => 'owncloud', 'dbpassword' => 'xxx', 'enable_previews' => true, 'installed' => true, 'instanceid' => 'xxx', 'maintenance' => false, 'memcache.local' => '\\OC\\Memcache\\APCu', 'theme' => '', 'forcessl' => true, 'loglevel' => 0, 'log_rotate_size' => 104857600, 'trusted_domains' => array ( 0 => '', 1 => 'xxx', 2 => 'xxx', 3 => 'xxx', ), 'secret' => 'xxx', 'appstore.experimental.enabled' => true, 'trashbin_retention_obligation' => 'auto', 'updater.server.url' => 'https://updates.nextcloud.org/updater_server/', 'updater.release.channel' => 'stable', 'updater.secret' => 'xxx', ); The output of your Apache/nginx/system log in `/var/log/apache2/`: nothing for some seconds before and after executing cron.php

Additionally to cron.php, occ didn’t work.
Switching from php5.6 to php5 (5.5.9) fixed it.