[SOLVED] Confused about Owncloud Apps in my Nextcloud Install


I’m running Nextcloud 10.0.3, which I upgraded to from 10 (originally the server was NC9, but I’ve used the updater app to keep it current). I’m on the stable channel.

I noticed during the upgrade to 10.0.3, several apps are not considered official. For example, Calendar Documents, and Contacts are considered “Approved” and not “Official.” But what’s more interesting, is that the Contacts app on my server is the Owncloud version, not the Nextcloud version. These apps were installed simply by clicking on “Apps” and then enabling them. I did not install anything third party. So I wonder, why doesn’t this enable the Nextcloud version of Contacts, instead of the Owncloud version?

I don’t see a way to install the Nextcloud contacts app. The official Github page for Contacts says to simply enable it:

But that seems incorrect in my case, as on my server, I have this one instead:

The strange part is that I never installed the Owncloud contacts, so I can only think that something is clearly wrong with my installation. How can I ensure I’m getting Nextcloud versions of my apps, rather than the Owncloud versions?

Did you check your config.php if “appstoreurl” is set there?

According to this at least since version 11 that option is not used anymore, but maybe in version 10 it still is.

Try to set it to 'appstoreurl' => 'https://apps.nextcloud.com/api/v1', the new nextcloud store api.

Thank you for the reply. On my installation, config.php does not have that option. Should I still add it?

I went ahead and added that config. It marked the apps as expiremental. I removed them, thinking it would allow me to install the correct apps. Unfortunately, I cannot get these apps back (they aren’t available under “not enabled”), and my server is useless now.

Edit: Solved.
I manually upgraded to NC11 following the instructions in the documentation. I moved my old NC directory and replaced it with a new one, migrating the config over. (Basically, what the documentation said to do). Immediately, I was able to install the missing apps. The only manual app install I had to do was to download the Tasks app, which wasn’t available in the app store on NC, despite being in the app store when I browsed it manually.

All set now, but I have no idea how I ended up with a hodge-podge of Owncloud and Nextcloud apps. I’ll never know, since I’m no longer using my old installation.

Ah sorry, I forget to mention 'appstore.experimental.enabled' => true, in this case to show experimental apps. In nextcloud 11 all appstore related settings are ignored, the appstore url is hard coded and there are no apps marked/markable as “experimental” anymore.

If this was a reason now for you to upgrade to nextcloud 11, at least it had some good result in the end ;).

€: Besides: The tasks app should be shown under “organization” category, at least for me it does.

Yes, NC11 is really nice so far. So it did work out.