[Solved] Collabora Office, not loading in firefox/chrome on nginx

I solved my problem by myself but I just wanted to give some feedback.
Maybe this helps someone else.

Debian 9, nginx, Letsencrypt SSL Certs, nextcloud 14, Collabora in a Docker
nextcloud on subdomain (cloud), Collabora on subdomain (office)
I did everything as mentioned in the nextcloud/Collabora guides.

In the end collabora wasn’t loading on Firefox and Chrome (blank screen with blue nextcloud header).
Only MS Edge could load Collabora Office. In Edge everything worked fine.

The firefox Debug console complained about multiple Header X-Frame-Options “SAMEORIGIN”
So I removed all X-Frame-Options in the nginx subdomain config files.
But still Collabora wasn’t loading. And the Firefox debugger still complained.

Weeks later by coincident I found in my /etc/nginx/snippets/ssl-params.conf file:
add_header X-Frame-Options DENY;
(Don’t know, when I put it there. I don’t think this is by standard.)

Removed it, now every broswer can load Collabora Office. Yeah!
I’m happy. Wanted to share my joy.

Thanks for this great project.
Greetings Daniel