[SOLVED] Collabora App not enabled

I’ve look up some related topics such as this:

Some people did mentioned the WOPI::CheckFileInfo returned: {"message":"App is not enabled"} problem but with no solution. What does the log mean “App is not enabled”? I’ve already enabled the docker image and the collabora app in Nextcloud 9.0.53. I’m running Nextcloud on Ubuntu 14.04.5 with 4.2 Wily kernel.

wsd-00020-02 06:58:57.254628 [ client_ws_000c ] WOPI::CheckFileInfo returned: {"message":"App is not enabled"}
wsd-00020-02 06:58:57.254869 [ client_ws_000c ] ~DocumentBroker [https://bblabcloud.bime.ntu.edu.tw/index.php/apps/richdocuments/wopi/files/581530?access_token=Cs6huQKCksUeuLDb9Fw8C4b3ccT0BOVe] destroyed with 0 sessions left.
wsd-00020-02 06:58:57.254896 [ client_ws_000c ] ~ChildProcess dtor [20116].
kit-20116-00 06:58:57.183729 [ loolkit ] Connection closed.
kit-20116-00 06:58:57.183784 [ loolkit ] SocketProcessor finishing. TerminationFlag: 0, n: 2, payload size: 2, flags: 88
kit-20116-00 06:58:57.183800 [ loolkit ] SocketProcessor finished.
kit-20116-00 06:58:57.183813 [ loolkit ] Removing '/lo'
kit-20116-00 06:58:57.336925 [ loolkit ] Removing '/user/docs/'
wsd-00020-00 06:58:57.408360 [ prison_ws ] Connection closed.
wsd-00020-00 06:58:57.408402 [ prison_ws ] SocketProcessor finishing. TerminationFlag: 0, n: 0, payload size: 0, flags: 0
wsd-00020-00 06:58:57.408430 [ prison_ws ] SocketProcessor finished.
wsd-00020-02 06:58:57.408506 [ client_ws_000c ] Closing child [20116].
wsd-00020-02 06:58:57.408536 [ client_ws_000c ] ClientRequestHandler::handleRequest: BadRequestException: Invalid URI or access denied.
wsd-00020-02 06:58:57.408546 [ client_ws_000c ] Thread finished.
wsd-00020-10 06:58:58.138672 [ loolwsd ] Total memory used: 216628
kit-20116-00 06:58:58.337186 [ loolkit ] Process finished.
frk-00029-00 06:58:59.057532 [ loolforkit ] Child 20116 has exited, removing its jail '/opt/lool/child-roots/20116'
wsd-00020-10 06:59:23.186242 [ loolwsd ] Total memory used: 216708

For me the issue was that I restricted the Collabora app to admin group only, which caused the docker not to be able to access the file(s) it wanted to edit. Once I removed that restriction it started to work.

1 Like

Thanks! It works now, but pretty much unstable. The files can be loaded in several retry with the same file.

Hi together,

I have the same “problem” not all users want to use Collabora - so I restricted the Collabora App to a special group. Then I get an connection error.

Is there perhaps a workaround for this?

Cheers,
Andreas