SOLVED - Can't reverse sharing / no options for sharing

Nextcloud version: 15.0.5
Operating system and version: Ubuntu Server 18.04.2 LTS
Apache or nginx version: 2.4.29-1ubuntu4.5
PHP version: 7.2.15-0ubuntu0.18.04.2

The issue you are facing:
I want to share a folder with a friend per email. The friend doesn’t have a nextcloud account, so i wanted to share with a link. In the past, this worked like it used to be with a lot of different options like a password, or an expire date. Now i can only choose if he can edit or not (“kann bearbeiten” in german). And i am not able to unshare the folder:

I also tried to share with another user of my nextcloud, but there is the same problem.

Is this the first time you’ve seen this error? Yes

Steps to replicate it:

  1. Try to share a folder or a file at the web interface
  2. You only can choose if the user is able to change (“kann bearbeiten” in german) or not
  3. You are not able to unshare the folder again

The output of your Nextcloud log in Admin > Logging:

no log entry at the current date

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => 'xxxxxxxxxx',
  'passwordsalt' => 'xxxxxxxxxxxxxxxxxx',
  'secret' => 'xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx',
  'trusted_domains' => 
  array (
    0 => '192.168.178.xx',
    1 => 'xxxxxxxxxxxxxxxxxxxxxxxxx',
    2 => 'xxxxxxxxxxxxxxxxxxxxxxxx',
  'datadirectory' => '/srv/nextcloud/',
  'overwrite.cli.url' => 'https://192.168.178.xx/nextcloud',
  'dbtype' => 'mysql',
  'version' => '',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'oc_xxxxx',
  'dbpassword' => 'rs4/xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx',
  'installed' => true,
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'redis' => 
  array (
    'host' => 'localhost',
    'port' => 6379,
  'cache_path' => '/tmp',
  'maintenance' => false,
  'theme' => '',
  'loglevel' => 2,
  'mail_smtpmode' => 'smtp',
  'mail_smtpauth' => 1,
  'mail_from_address' => 'xxxxxxxxxxxxxxxxxxxxx',
  'mail_domain' => '',
  'mail_smtpsecure' => 'tls',
  'mail_smtphost' => '',
  'mail_smtpport' => '587',
  'mail_smtpname' => 'xxxxxxxxxxxxxxxxxxxxxxx',
  'mail_smtppassword' => 'xxxxxxxxxxxxxxxxxxxxx',

The output of your Apache/nginx/system log in /var/log/____:

there is no such thing

Another user had a similar problem and that was solved with disabling the ad blocker. Do you have one running?

1 Like

Thank you SmallOne. That was the problem. Adblockers are bad for your Nextcloud :thinking:

@furby what adblocker are you running?

@SmallOne: Sorry for not answering your question in time. In April i just switched from Adblock Plus to uBlock Origin and didn’t deactivated it on my nextcloud-site.