[SOLVED] "Cannot GET" Problem starting Nextcloud after certificate and Ubuntu Server update

Hello, everyone!

I followed this tutorial and my Nextcloud Hub has been working flawlessly ever since. Shout-out to the author: Great Job!

This is the error message I receive as I try to start the docker/Nextcloud:

The last couple of weeks I have received a warning by e-mail that my certbot Letsencrypt certificate was going out of date. Today I thought I’d do something about it.

  1. Since it was the first time for a long while that I actually opened up the server to work on it, it asked me to do some updates on the system.

  2. I went to the certbot page where the instructions I previously had followed were found. I followed them and I get a “Congratulations!” in the terminal window.

  3. My computer restarted because the updates to Ubuntu Server were ready.

  4. I tried to enter Nextcloud in Firefox and received this:

I tried entering by the global IP-address, with the local IP-address, with the server domain url. All of them hands me back this “Cannot GET” answer. However, the Collabora domain URL gets me to the Apache2 default page and the Only Office server url directs me to the Only Office Welcome screen.

  • At some point I tried to update the Nextcloud installation to a newer version. From 20.0.4 to 20.0.8? I clicked “open updater” but nothing seemed to happen. Clicked that several times. I also downloaded the Nextcloud update files. (I do not get how I will go through with the update).

What can I do to fix this problem?

Thanks for your help!

PS. I am not sure about my IP-configuration in my WAN-settings on the router. There is a Service Name called TURN with the External Port 3478. I cannot remember setting that up.

The real question here is, your certbot was obviously set up and working before, so why did it stop? If you run certbot again from the CLI does it renew successfully?

There are several things that could be going on here. Make sure your Docker containers are all up and running and that your disk isn’t full.

You don’t update using the normal procedure when using Docker. You update by pulling new versions of the containers.

This is for coturn. It’s used by Nextcloud Talk.

As always, I owe you a great deal of gratitude for trying to help me out. Thanks!

Here is what seems to be the problem:

Any ideas?

Yep, that last line shows you what the problem is. The Nextcloud Docker container is configured to use TCP port 8080, but something else on your system has the port in use, so Docker fails to start the container.

To find out what it is, you can run: sudo ss -4tnlp

Thank you for getting back on this!

I got this output:

No port 8080, no port

But the looks a tad strange…?


/Martin Book

I used another command (sudo lsof -i:8080) and got the following result:

Could the spell checker be the disturbance? Or Apache2?

Could be. You can get a list of your Apache sites and listening ports with: sudo apachectl -S

If your system has netstat installed, you can also try using that: sudo netstat -lntp

Here is the output for apachectl

Here is the errorlog

Here is the output for netstat

Seems like the spellchecker is on the 8080 port. Should I try to just uninstall that or is there anything else I can do?


I have now tried to kill the process called spellchecker but it just starts up again immediately (with a different PID). Is there a way to disable spellchecker from that port or just uninstall it altogether? I think it is the Collabora spellchecker that I tried to install but have not been able to make function properly anyway.

Aha! It is the OnlyOffice Spellchecker. (used command ps -Flww -p PID)

Now, how do I remove that?

I have solved the problem! Thanks to KarlF12 for giving me some pointers!

All in Terminal below:

  1. I used sudo apachectl -S and sudo netstat -lntp to get information about what was running on port 8080. It was the OnlyOffice Spellchecker that was busy on the port I needed for Nextcloud.

  2. I found more information about the process by entering ps -Flww -p PID with PID being the Process ID that you get from the above commands.

  3. I needed to uninstall OnlyOffice to remove the Spellchecker. I uninstalled OnlyOffice by entering apt remove onlyoffice-documentserver since my OnlyOffice instance was on the community document server and not in a docker image.

  4. After the uninstallation was finished my Nextcloud works fine again! Hurrraaayy!

Hope this might help someone else.

Martin Book