[SOLVED] Broken Nextcloud Login & Home page, fresh install

I had recently decided to replace my existing ownCloud 10.0.8 installation with Nextcloud 13.0.4 on my subdomain cloud.website.com. After successfully installing and logging in, i found that the CSS & JS was broken (similar to https://github.com/nextcloud/server/issues/7905) on the dashboard page (I am unable to show this as i am unable to login, which leads to my next problem); The login page is also broken (clicking Login or hitting enter after entering credentials does nothing). Inspect > Console on Chrome shows various Uncaught ReferenceError: OC is not defined & Uncaught ReferenceError: OCA is not defined errors.

I’ve also been receiving these duplicate messages on my nextcloud.log.

{"reqId":"W0XZN9uZMeapoDv5Skfm5AAAAA8","level":3,"time":"2018-07-11T10:17:28+00:00","remoteAddr":"","user":"--","app":"PHP","method":"GET","url":"\/index.php\/login","message":"fopen(): https:\/\/ wrapper is disabled in the server configuration by allow_url_fopen=0 at \/home\/user\/public_html\/cloud\/lib\/private\/Files\/ObjectStore\/S3ObjectTrait.php#68","userAgent":"Mozilla\/5.0 (Macintosh; Intel Mac OS X 10_13_5) AppleWebKit\/537.36 (KHTML, like Gecko) Chrome\/67.0.3396.99 Safari\/537.36","version":""}

{"reqId":"W0XZN9uZMeapoDv5Skfm5AAAAA8","level":3,"time":"2018-07-11T10:17:28+00:00","remoteAddr":"","user":"--","app":"PHP","method":"GET","url":"\/index.php\/login","message":"fopen(https:\/\/s3.ap-southeast-1.amazonaws.com\/nextcloud\/urn%3Aoid%3A152): failed to open stream: no suitable wrapper could be found at \/home\/user\/public_html\/cloud\/lib\/private\/Files\/ObjectStore\/S3ObjectTrait.php#68","userAgent":"Mozilla\/5.0 (Macintosh; Intel Mac OS X 10_13_5) AppleWebKit\/537.36 (KHTML, like Gecko) Chrome\/67.0.3396.99 Safari\/537.36","version":""}

Server configuration:
Operating System: Centos 7
Web serer: Apache
Database: mySQL
PHP version: 7.1

Steps to reproduce:
ownCloud uninstallation on cPanel:

  1. Deleting the subdomain cloud.website.com.
  2. Removing existing owncloud installation directory from file manager.
  3. Deleting the existing mySQL Database & database user associated with ownCloud.

Nextcloud installation:

  1. Recreating cloud.website.com subdomain on cPanel.
  2. Create new mySQL Database & Database user.
  3. Upload, extract, and moving Nextcloud files to subdomain root. (Nextcloud downloaded from https://nextcloud.com/install/#instructions-server)
  4. Editing the config.php file (To use S3 as primary storage)
    'objectstore' => array ( 'class' => 'OC\\Files\\ObjectStore\\S3', 'arguments' => array ( 'bucket' => 'nextcloud', 'autocreate' => true, 'key' => 'XXXXXXXXXXXXXXXXXXX', 'secret' => 'XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX', 'hostname' => '', 'port' => '', 'use_ssl' => true, 'region' => 'ap-southeast-1', 'use_path_style' => true ), ),
  5. Completing the installation on my subdomain.

Additionaly the command sudo -u www-data php /var/www/nextcloud/occ app:disable theming suggested didn’t fix anything for me. Any other suggestions would be appreciated! :slight_smile:

Edit: I found the problem. I had to enable allow_url_fopen on my server.
For WHM users:


Please try this solution:

If that didn’t solve your problem, please read this thread:

It contains ideas that helped some people. Clearing the browser cache and checking a google cache (didn’t read all responses that carefully) and a broken web server config were solutions for example.