[Solved] Automatic Update from 12.0.3 to 12.0.6 failed

Nextcloud version 12.0.3:
Operating system and version:
Linux dd12930 3.13.0-135-generic #184-Ubuntu SMP Wed Oct 18 11:55:51 UTC 2017 x86_64)_:
Apache or nginx version Apache 1.3:
PHP version 5.6.32-nmm1

Is this the first time you’ve seen this error?:

Can you reliably replicate it? (If so, please outline steps):
not possible

The issue you are facing:
After the automatic update process all programm files are deleted.
I uploaded the source files
but nextcloud tells me that an update process is running

The output of your Nextcloud log in Admin > Logging:
Lost the original message, write problems where the cause.
admin/log is not available

What can I do to end the update process

automatic update to 12.0.6 fails? well… that’s easy. there simply isn’t such a version, yet.

I think that is what the process showed me.

Can you help me, what to do to end the Update-Modus?

All the programm file had been deleted. So I uploaded all the sources from 12.0.3
But if I call the index.php, it tells me, that the update process is running.


The version 12 update is to 12.0.4. The update for 11 is 11.0.6. Did you try and run the updater for version 11 on a version 12 instance?

I didn’t run any additional programm.
I saw at the webside a button ‘new update available’ witch I clicked.

The update process crashed because of .htaccess redirect problems

I need help, how can I cancel that updete mode, whitch prevents the login.


I ran into a similar problem. The solution is pretty simple, just follow the manual upgrade process instead.

I deleted everything except config and data.
I uploaded my source files 12.0.3, which was the original version.

When i call domain.de/nextcloud I get following message

This Nextcloud instance is currently in maintenance mode, which may take a while.
This page will refresh itself when the Nextcloud instance is available again.
Contact your system administrator if this message persists or appeared unexpectedly.
Thank you for your patience.

Thanks für any help to rescue my data and users


Try disabling maintenance mode using one of the two methods:

sudo -u www-data php /var/www/nextcloud/occ maintenance:mode --off


Edit config.php and set ‘maintenance’ => false,

And possibly restart Apache to reflect the change.

If this method works for you to restore your current version, you should be able to use the same method to install the new version, just be sure to follow through all the instructions in the manual, especially doing the database upgrade :slightly_smiling_face:


unfortunaly I have no root- or terminal-access.

I set $maintanance=false;
Then the following message came up:

Nextcloud will be updated to version 12.0.3
These apps will be updated:
Activity (activity)
Comments (comments)
WebDAV (dav)
Federated file sharing (federatedfilesharing)
Federation (federation)
Files (files)
PDF viewer (files_pdfviewer)
File sharing (files_sharing)
Text editor (files_texteditor)
Deleted files (files_trashbin)
Versions (files_versions)
Video player (files_videoplayer)
First run wizard (firstrunwizard)
Gallery (gallery)
Notifications (notifications)
Password policy (password_policy)
Provisioning API (provisioning_api)
Monitoring (serverinfo)
Usage survey (survey_client)
Collaborative tags (systemtags)
Theming (theming)
Update notification (updatenotification)
Files workflow engine (workflowengine)
Please make sure that the database, the config folder and the data folder have been backed up before proceeding.

And a Button: Start Update
I pressed the Update-Button and the following message appears

Exception: Updates between multiple major versions and downgrades are unsupported.
Detailed logs
The update was unsuccessful. For more information check our forum post covering this issue.

Please help me that the slogan:
“The safe home for all your data” becomes true.


So, I’m not totally clear on which version you are currently using, and which version you are trying to upgrade to. You say that you currently have 12.0.3, which sounds fine. Then which version do you want to upgrade to? 12.0.6 does not exist as mentioned earlier.

From the error message, it sounds like maybe something is getting lost in translation here, and really you have 11.0.6 and are trying to upgrade to 12.0.3.

In that case, check out this thread which may or may not help you: Cannot manually upgrade from 11.0.3

I’m not shure, I thought it was 12.0.3.
I have the sources from 12.0.3 on my local computer, so I’m shure that this version was installed.
But I have some installations of netxcloud so, maybe I’m wrong and it was an older version.

the config looks like this:
$CONFIG = array (
‘instanceid’ => ‘oc***3y’,
‘passwordsalt’ => ‘aka*nD’,
‘secret’ => 'kTn’,
‘trusted_domains’ =>
array (
0 => '.de’,
‘datadirectory’ => ‘/www/htdocs/w0101911/cloud/data’,
‘overwrite.cli.url’ => 'https://
‘dbtype’ => ‘sqlite3’,
‘version’ => ‘’,
‘logtimezone’ => ‘UTC’,
‘installed’ => true,
‘loglevel’ => 1,
‘updater.secret’ => '$2
‘maintenance’ => false,
‘theme’ => ‘’,

Mysteriously there is a version
The config in the backup-folder looks simmilar.
Is it possible that I run a 12.0.3 and the config was old?
Maybe this happen, because I did alwas manualy updates?

What can I do to migrate the datebase or at least to find out whitch version the database is?

My next step will be to extract 12.0.4 and upload that sources to the server.
Any other advises is welcome!!


I’m not sure if this is helpful, but I found this in the database:

SELECT oc_appconfig.configvalue FROM oc_appconfig WHERE oc_appconfig.configkey = "core"

I have a feeling that will tell you which version your database is at.

It tells me ??
How can I get a clean installation, without loosing my data?

I’m wondering, why it rän with the new sources and never mentioned that something is inconsistent?
I think I copied the sorces 12.03 to the instance and run it.
The problem startet, with the automatic update process, with suggested an automatic update. And now the update modus don’t come to an end and everything is blocked.

In the manal Upgradprocess a access via terminal is needed. I don’t have that. Is an upgrade possible without terminal access?


OK, the issue is solved.

I uploaded the 10.0.1 and everything runs fine (with reduced features)

Thanks for all responses and discussion
Greetings Udo I was going to say, try upgrading to NC 10 and see what happens, then try 11. I couldn’t quickly find the info on which version code goes with which NC version, but I remember something about NC 10.x actually having the 9.1.x version code internally, something to do with the transition away from ownCloud’s versioning scheme.

Keep going, upgrade one major version at a time until you’re fully up to date. It’s not just about features, but they keep hardening the security too.

I’m not sure about the upgrader, but I would agree that it could be a little more user friendly in the case where the upgrade doesn’t go according to plan. And it seems like checking the version would be a little more robust so you don’t end up in the situation you were in. There’s always the issue tracker on Github :slight_smile: